iPad / iPhone Bug?

Visual VoodooVisual Voodoo Beginner grinnerSan Diego, CAPosts: 70Registered Users Big grins
edited December 5, 2016 in Bug Reporting
Hi. Has anyone had issues with the iPad or iPhone versions of the website panning the wrong way? What I mean by that, is if you flick the page up or down to pan through your site and you do it can accidentally to the side, you get a weird pan where your not really looking at your site correctly. Maybe a bug?

Here is an example from my iPad (Pro 9.7) and my iPhone is the 6+. Both are fully OS updated. The first image is the way the site is suppose to look like...the 2nd image what you get if you don't flick or pan perfectly with your finger...

Someone will probably say, "well don't do that" but I look at the site and browse the way I think people will do it...so I can't just tell a customer not to do that (grin). So my point is: either this is a bug or maybe I may need some CSS to fix it. Interested in if you guys have experienced the same on your sites.

image2.png

image1.png

Comments

  • Visual VoodooVisual Voodoo Beginner grinner San Diego, CAPosts: 70Registered Users Big grins
    edited December 4, 2016
    Ok now with the iPhone its ALOT worse... Here are some photos. I was in landscape mode and portrait mode, and if you swipe the screen up or down and it moves, but if you flick it left or right there appears to be a big bug. I can slide an image almost completely off the screen. Silly. Ok so here is the screen before you do anything...
    image3.png

    No flick the page to the side...going going...

    image4.png

    And now there is nothing
    image2-1-1.png
  • leftquarkleftquark SmugMug Product Team Posts: 3,462Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee
    edited December 5, 2016
    That behavior is caused by your HTML / CSS content block controlling your footer:
    .sm-page-widget.sm-page-widget-16459290 footer {
        [COLOR="Red"]width: 980px;[/COLOR]
        height: 68px;
        margin: 0 auto;
        border: 0 solid #000;
        text-align: center;
        background-color: #1c1c1c;
    }
    

    I've changed "width: 960px;" to "width: 100%;" and the issue has been fixed. Let me know if I can help in any other way!
    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • Visual VoodooVisual Voodoo Beginner grinner San Diego, CAPosts: 70Registered Users Big grins
    edited December 5, 2016
    Thank you. I appreciate that! Fixed.
  • Visual VoodooVisual Voodoo Beginner grinner San Diego, CAPosts: 70Registered Users Big grins

    Hey thanks. That was great.

Sign In or Register to comment.