Lightroom Plugin Bug (Feature?) - a problem related to "replace an image"

FergusonFerguson Major grinsFort Myers, FloridaRegistered Users Posts: 1,326 Major grins

I think this is new (as in last year or so) behavior, but I am not at all sure, maybe it always worked this way, but it presents a real problem for me.

When you update a photo's metadata in Lightroom, the Smugmug plugin only publishes the metadata, it does not send the original image again. I knew that, I am not exactly happy, but I understood it.

I THOUGHT that in the past if you marked it up-to-date, then marked it to republish, the "mark to republish" was absolute, and would send the image itself in addition to metadata. It does not.

This presents a challenge. Some of us (well, at least one of us) want the images we deliver via Smugmug (e.g. via Download Original) to actually have all the metadata inside of them, from copyrights to keywords. Which means if we do metadata updates, we need a way to re-transmit the image (not just the keywords) to Smugmug, since Smugmug does not (rightly so) touch the original image.

In the past, I would just "Mark To Republish" and I thought I was good. The only trick was you sometimes had to either tell it twice, or mark as up-to-date. But I just confirmed this morning that if you Mark To Republish it ONLY sends metadata unless the image has changed.

So Smugmug is checking the actual development settings, I think, and determining it does not need to be sent again.

Worse, I tried doing something simple -- click up one on tint, then down one on tint -- that did not do it either, it recognized it was unchanged.

Well I WANT it unchanged, but because of the way Smugmug works, I NEED it sent again so it is up to date with metadata.

And, before someone suggests - No, I cannot remove it from the collection and add it again, because that changes the URL's.

This means for some unknown amount of time, quite possibly forever, I've been delivering images to people with incorrect or incomplete metadata, despite my best efforts to upload them.

This whole LR/Smugmug synchronization thing is getting out of hand in complexity. I JUST WANT TO REPLACE AN IMAGE AND HAVE IT ALL REPLACED, EASILY, COMPLETELY.

Now I'm not only stymied on the SM server front with conflicting handling of things like date and time, but on the Plugin side, with no way to actually say "replace" apparently.

Am I the only one who just wants to replace an image, completely, simply?!?

HELP!?

Tagged:

Comments

  • FergusonFerguson Major grins Fort Myers, FloridaRegistered Users Posts: 1,326 Major grins

    Question, if by chance Dave stops by to this: Yes, I know one should never change the catalog with SQL. Sure. Acknowledged. But... Is there a value in the catalog somewhere that I can flip/change/force that would say "LR Plugin please upload the whole image again"? I don't mind doing it manually like that, I just need a way to DO it?

  • leftquarkleftquark Former SmugMug Product Team Registered Users, Retired Mod Posts: 3,769 Many Grins

    Hi Ferguson,
    I do and have been doing exactly what you describe quite often. Lately I've been frustrated because Lightroom doesn't acknowledge that photos edited outside of Lightroom (for example in Photoshop) have changed and doesn't flag the photos for republish (turns out this is a bug on Adobe's end and I've trying to get them to fix it on their end). For my TIFF's that I edit in Photoshop and re-save, I have to manually mark them to republish. Marking the photos to be republished has always resulted in sending the full file (metadata AND pixels included) up to SmugMug and it's been working this way up to ~2 weeks ago.

    I just doubled checked and marked the photo to be republished did in fact send both the metadata and the pixels to smugmug using both SM Publish Plugin 3.1.1.0 and version 3.1.2 using LR CC 2015.10. I tested by making the photo Black and White, marking it as up-to-date, then marking it to republish, and clicking publish. The black and white version went up to SM. I repeated the process to return it to color and the color version was displayed on SM. Am I doing something differently than you are?

    dGrin Afficionado
    Former SmugMug Product Team
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • FergusonFerguson Major grins Fort Myers, FloridaRegistered Users Posts: 1,326 Major grins

    Yes, you are making an actual change in the photo, that works fine (though thanks for the reminder, I'm on 3.1.0.0 I think, I keep saying "remind me later", but nothing in the release notes looks relevant).

    Try this: Make a change, like black and white, and republish. Just to make sure you know what's up there. Note the caption on the image at that time.

    Then change ONLY metadata, like the caption.

    Now mark as up to date (your change marked it for republish), then mark to republish.

    Publish.

    Download the original image from Smugmug, and look at the metadata -- you'll see the old caption because it did not send the image. (At least I hope it does, otherwise I'm losing it).

    This came up today because I found I had mis-spelled someone's name in dozens of photo captions and keywords. In about 12 different galleries. I got a rather annoyed email this morning letting me know. Fixing them was fast in Lightroom, but at this point I have no idea if I managed to get them all to upload again (and no real idea how to tell). I'd love to just find them all (that's trivial) and say "this has changed" and make them go up. But anything that causes that ALSO seems to actually, really cause an image change.

    The best I've come up with (since writing this) is to do it twice. E.g. up the exposure 1/3 stop in quick develop. Publish everything (now for a time everything is too bright). Then down it 1/3 stop, and publish everything.

    You can't do the up/down without publishing or it just resets. I guess doing clarity would be less disruptive than exposure... maybe I should go do that right now, just to make sure.....

  • leftquarkleftquark Former SmugMug Product Team Registered Users, Retired Mod Posts: 3,769 Many Grins

    I just edited the title and caption -- the first time LR acknowledges that it's been edited and when I click publish, it sends just the metadata (publish was super speedy). I then "Mark to Republish" a second time and clicked publish (publish took a look time). When I refresh the photo on SM and then download it, the metadata is embedded in the photo.

    :confounded:

    dGrin Afficionado
    Former SmugMug Product Team
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • leftquarkleftquark Former SmugMug Product Team Registered Users, Retired Mod Posts: 3,769 Many Grins

    dGrin Afficionado
    Former SmugMug Product Team
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • FergusonFerguson Major grins Fort Myers, FloridaRegistered Users Posts: 1,326 Major grins

    OK, let me set this up again and test it.

    You didn't change any develop settings at all, right?

    Also, I'll update the plugin, though not until I test again.

    I'm happy if republish really does.

  • FergusonFerguson Major grins Fort Myers, FloridaRegistered Users Posts: 1,326 Major grins

    By the way, spectacular image.

  • leftquarkleftquark Former SmugMug Product Team Registered Users, Retired Mod Posts: 3,769 Many Grins

    @Ferguson said:
    You didn't change any develop settings at all, right?

    Correct! Just left everything as it was and only changed the title/caption text.

    dGrin Afficionado
    Former SmugMug Product Team
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • FergusonFerguson Major grins Fort Myers, FloridaRegistered Users Posts: 1,326 Major grins

    OK, this is what I did. Windows 10 (fully updated, but not the new creator), LR 2015.10 x 64 bit, LR Plugin 3.1.0.0 (2 steps back I think, I'll update and post again after this).

    I put three images without captions in a test gallery. Their (current) URL's are here, along with what I did to each. I will leave these unchanged if you care to look at them:

    https://photos.smugmug.com/photos/i-NThZSWs/0/0ca08f81/O/i-NThZSWs.jpg

    1) Published with no caption
    2) Changed caption to "New Caption - no republish yet"
    3) Published

    It downloads with no caption.

    https://photos.smugmug.com/photos/i-SmjmD2k/0/90a0e664/O/i-SmjmD2k.jpg

    1) published with no caption
    2) Changed caption to "New caption, mark updated, mark republished".
    3) Marked as up to date (the above changed it to modified)
    4) Marked for republish
    5) Published

    It downloads with no caption, which i think is wrong.

    https://photos.smugmug.com/photos/i-X78km9n/1/e06a31a0/O/i-X78km9n.jpg

    1) Published with no caption
    2) Changed caption to "No caption, then caption, then change clarity" (this marked it to republish, and I left it there)
    3) Changed clarity up one
    4) Publish

    This one downloads with the caption as expected, so it re-sent the entire image.

    The middle one is the problem, and I was quite careful in what I tried (indeed, you should be able to see the updates yourself in the logs, though I guess not what happened in LR).

    I'll grab the latest copy of the plugin and try the middle test again. Is what I did what you also tried? Do you see a difference?

  • FergusonFerguson Major grins Fort Myers, FloridaRegistered Users Posts: 1,326 Major grins

    OK, just updated the plugin to the latest, 3.1.2. I shut down lightroom and restarted after the install.

    First, one minor correction: I am changing the title, not the caption, sorry, so the above is slightly wrong.

    I then uploaded yet another image.

    https://photos.smugmug.com/photos/i-RVWGHZX/0/32d1bc7c/O/i-RVWGHZX.jpg

    I did these things, in order:

    1) Upload with publish (it has no caption or title.)
    2) Changed the title to "Changed caption, then mark updated, then mark to republish"
    3) At this point it shows modified, I right click and set to up-to-date
    4) It pops back down into the published -- I right click on it, and "Mark to republish".
    5) Press Publish

    It ran very fast, and I downloaded the SM image (after doing a "Show on SMugmug" fresh) and it came down without a caption. The SM display of course showed the caption.

    Windows vs Mac?

    Senility? (but you're not that old? :wink: )

    Something subtle I am doing different from you? That's why I tried to be overly detailed.

  • leftquarkleftquark Former SmugMug Product Team Registered Users, Retired Mod Posts: 3,769 Many Grins

    The only difference is that I did the double re-publish. After publishing with just the metadata change, a second "Mark to Republish" causes the full item to be uploaded.

    I'll talk to David but from previous conversations I think he's trying to be smart: he knows that only the metadata is out of sync, so that's all he publishes so that the changes go up very quickly. The second one is you saying "no, I really want the whole thing uploaded"

    dGrin Afficionado
    Former SmugMug Product Team
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • FergusonFerguson Major grins Fort Myers, FloridaRegistered Users Posts: 1,326 Major grins

    @Lefquark, I think you have it.

    It appears if I change metadata only it only copies that, EVEN if you mark up to date, then mark to republish.

    But if you let it publish FIRST, then (with no other changes) mark to republish, it sends the image.

    My guess is he says "republish" and checks if anything has changed. If metadata has, he sends just that, but if nothing has changed he sends the image? If that's it, I can work with that now that I understand it.

    But gesh... it's getting hard to work around all the quirks to replace an image. :'(

Sign In or Register to comment.