Social icons blocked in FireFox

WolfbetaWolfbeta Beginner grinnerPosts: 8Registered Users Beginner grinner
edited June 2, 2014 in Bug Reporting
Firefox 23 and up blocks iframes. Since the social buttons are integrated using iframes instead of XFBML or HTML5 they only appear in Chrome and IE. By using inspect element you can see that FireFox still processes the code, it just doesn't render the iframe.

Two options exist to correct this. switch over to HTML5 for social integration, or serve iframes through a secure connection.

Comments

  • mrneutronmrneutron Support Hero Posts: 214Registered Users Major grins
    edited May 31, 2014
    Sorry, SmugMug does not support embedding your site in an iframe at this time.
    Andy K
    SmugMug Support Hero
    help.smugmug.com
  • WolfbetaWolfbeta Beginner grinner Posts: 8Registered Users Beginner grinner
    edited June 1, 2014
    Nice reading comprehension.
  • pbandjpbandj Major grins Posts: 238Registered Users Major grins
    edited June 1, 2014
    Wolfbeta wrote: »
    Nice reading comprehension.

    Maybe you should try again, a little more slowly. mwink.gif Perhaps it will help Smugmug understand the problem if you attach screen shots showing IE/Chrome vs. Firefox.
  • mbonocorembonocore Social Butterfly Posts: 2,299Registered Users Major grins
    edited June 2, 2014
    Social buttons work as desired on my Firefox.
  • ElunaryElunary Posts: 5Registered Users Big grins
    I've the same issue with social media icons not showing up in Firefox v52, but working fine in MS Edge(IE). The theme I'm using is Sierra. If I try customized default theme, the icons show up in Firefox just fine.
  • Hikin' MikeHikin' Mike Walkin' like a Penguin! Atwater, CaPosts: 4,419Registered Users Major grins

    @Elunary said:
    I've the same issue with social media icons not showing up in Firefox v52, but working fine in MS Edge(IE). The theme I'm using is Sierra. If I try customized default theme, the icons show up in Firefox just fine.

    Can you post your site?

  • ElunaryElunary Posts: 5Registered Users Big grins
    I haven't published that theme yet since it's not working properly.
    I've made some screenshots, but I don't see a way to post them here. Do I need to host them somewhere else?
  • Hikin' MikeHikin' Mike Walkin' like a Penguin! Atwater, CaPosts: 4,419Registered Users Major grins

    Since you're new I don't think you can post photos yet. I don't think screenshots are going to help. The helpers here will most likely want to see it live.

  • ElunaryElunary Posts: 5Registered Users Big grins
    I can't make that theme live, because it's not ready to be published, and I don't know if I want to finish it if it's buggy. So I was trying to figure out if this bug can be fixed in near future or should I look for other options.
  • Hikin' MikeHikin' Mike Walkin' like a Penguin! Atwater, CaPosts: 4,419Registered Users Major grins

    I use 'FontAwesome' to display my social icons on my site. So I added a Social Icon block on my testing site and they worked for me using Firefox.

  • ElunaryElunary Posts: 5Registered Users Big grins
    Like I said in the initial post, the problem persists in the Sierra theme. My default theme (I don't even know its name, the original one they rolled out with the switch to a new site layout) doesn't have this problem.
    It seems that due to a lack of answers from support, I will have to file a separate bug report via Smugmug. I was hopping for a faster resolution via this site.
  • Hikin' MikeHikin' Mike Walkin' like a Penguin! Atwater, CaPosts: 4,419Registered Users Major grins

    I use the Sierra theme.

    Yes, you will get quicker responses via the help desk.

  • ElunaryElunary Posts: 5Registered Users Big grins
    I tried to add a block of social media icons with the built-in theme option.
    Unfortunately, not in my experience, but I will try again.
  • rainforest1155rainforest1155 SmugMug Support Hero Posts: 4,495Registered Users Major grins

    Elunary,
    If you haven't done so yet, I would also suggest that you contact us Heroes on the HelpDesk with details. In your message also include a link to your site and if possible a screenshot of your whole screen showing the issue.
    It would also be helpful to know if you have any extensions installed in your Firefox and if so, which.

    Sebastian
    SmugMug Support Hero
Sign In or Register to comment.