Change password UI broken

roletterolette Major grinsPosts: 223Registered Users Major grins

Went to Account Settings to change my password in SmugMug. Entered my old password + new password + verify password, clicked on the "SAVE AND EXIT" button and... nothing.

The UI just sits there. No spinners indicating that there is a request being processed. Certainly not exiting the account settings or any other indication that I actually hit the save button. I eventually hit the CANCEL button and it went back to my main smugmug page:

Next I tried to go back into Account Settings to retry and it prompted me for my password. My old password no longer worked, so apparently despite any feedback from the UI a password change happened, it took. Of course, since I generate random one-off passwords with 1Password, I had no idea what the password was (password manager didn't capture the change because of the lack of feedback).

So, next adventure was going through password reset. Hit the "forgot my password" link, got the reset email and followed that link. Generated a new password and entered that, hit the submit/save/whatever-it-was-called button and once again, ZERO indication that I hit the button. While I was scratching my head over that piece of loveliness, after 1-2 minutes, the UI suddenly said my password was changed.

Chrome Version 65.0.3325.181 (Official Build) (64-bit)
macOS Version 10.13.4 (High Sierra)



Sign In or Register to comment.