'Feed' Content Block?

rjwilnerrjwilner USAPosts: 30Registered Users Big grins

What exactly is the Feed content block looking for to populate with content? I.e., is there a particular URL format required, or....?

I've tried adding one to a test page and have tried adding a variety of URL"s and all I ever get in the block is a 'No Feed Items' msg.

Comments

  • denisegoldbergdenisegoldberg Major grins North Andover, MAPosts: 12,316Super Moderators moderator

    I just tried adding a Feed content block to a test page on my site. I used the feed from my blog, created by Feedburner. I verified that the feed does show on the page where I placed it. Here's the URL of the feed, doesn't look like anything special: http://feeds.feedburner.com/DeniseGoldbergsBlog.

    Do you have a feed from another site that you are trying to place on your site?

  • rjwilnerrjwilner USAPosts: 30Registered Users Big grins

    @denisegoldberg said:
    I just tried adding a Feed content block to a test page on my site. I used the feed from my blog, created by Feedburner. I verified that the feed does show on the page where I placed it. Here's the URL of the feed, doesn't look like anything special: http://feeds.feedburner.com/DeniseGoldbergsBlog.

    Do you have a feed from another site that you are trying to place on your site?

    There has to be something specific the block is looking for. I put your feedburner URL in my block and as soon as I did so, without having saved or published anything, the block populated with your content. I wonder if maybe it only works with Feedburner. (And yes, I immediately turned around and removed your URL as soon as I saw the content populate on my side).

    The other odd thing is that any 'normal' URL I enter (...of the http:///somewhere.com/whatever.... variety) winds up creating an error as depicted in the attached. I.e., when I enter a Feed Title and then the desired URL, I click 'Done' and am returned to the page. But not only does the block display 'No Feed Items', it is also missing the typical content block toolbar. So, I try to click Done...assuming I would then be able to 'Discard Changes', but that's when the attached error appears. The only way I can get out of the mess is use the browser Refresh option. When I do that, then the content block toolbar appears and I can send it to the trash.

    Really odd behavior.

  • denisegoldbergdenisegoldberg Major grins North Andover, MAPosts: 12,316Super Moderators moderator
    edited June 8, 2019

    @rjwilner said:
    There has to be something specific the block is looking for.

    Where are you getting your feed from? Does it come from a feed service?

    I wonder if a particular type of feed is needed with the Feed content block. It might be worth asking the SmugMug help desk.

  • rjwilnerrjwilner USAPosts: 30Registered Users Big grins

    @denisegoldberg said:

    I wonder if a particular type of feed is needed with the Feed content block. It might be worth asking the SmugMug help desk.

    That would be my guess. It would seem it's looking for something that identifies the 'feed' as one from a blog. Will contact the Help Desk.

    Thanks for taking the time to check things out!

  • colourboxcolourbox Major grins Posts: 2,086Registered Users Major grins

    @rjwilner said:
    That would be my guess. It would seem it's looking for something that identifies the 'feed' as one from a blog. Will contact the Help Desk.

    I suspect that "from a blog" technically means, at the very least, that the URL must resolve to an feed using RSS (Really Simple Syndication) format. It might also support Atom, another common news feed format.

    That's typically how these things, like newsreader/feed reader applications, work. However, newsreader apps are usually smarter in that you can often just give them the regular www URL and it will look around on the site until it finds the right feed, and then links to that. But sometimes, as in this case, you need to be specific about the newsfeed URL, and it has to be the correct type right away.

    But yeah, the Smugmug Help Desk will be the one to give the definitive answer.

    (I use the Feed block to pipe in a list of my blog posts in, and it's worked fine for a long time.)

Sign In or Register to comment.