Smugmug and Internet Explorer 9

lenolilenoli Beginner grinnerPosts: 1Registered Users Beginner grinner
edited October 28, 2012 in SmugMug Support
Hello, I am using the release candidate of Microsoft Internet Explorer 9 and I am having some compatibility issues with using the smugmug sites.

First of all I am unable to upload pictures through the upload page.
Secondly the default gallery view with thumbnails on the left and a bigger picture on the right seems to get into a strange layout.

The final version of IE9 will be available before this summer according to Microsoft so I hope you guys are working on getting the issues with this browser fixed.

Regards,
Olivier

Comments

  • AndyAndy Bicameral New YorkPosts: 60,808Registered Users Major grins
    edited March 6, 2011
    lenoli wrote: »
    The final version of IE9 will be available before this summer according to Microsoft so I hope you guys are working on getting the issues with this browser fixed.

    Regards,
    Olivier
    We'll support it, when it's released for real. In the meantime, try the most excellent Firefox or Chrome, latest versions, we fully support them :)
  • naturalaperturenaturalaperture Beginner grinner Posts: 9Registered Users Beginner grinner
    edited April 7, 2011
    That is unacceptable. We pay for this service, and we expect it to work. Compatibility issues should have been dealt with *before* it started being rolled out. None of my galleries are displaying properly.

    It's one thing for you or I to use Chrome or Firefox, but quite another to ask every single potential client in the country to use a different browser.

    You're completely missing the point. It's not an issue of our websites rendering properly for us; it's an issue of our websites rendering properly for prospective clients, and to tell us to use another browser is just insulting. Personally, I use Firefox. However, the majority of PROSPECTIVE CLIENTS use IE. That's who we care about.

    So you're the COO... what does the CIO have to say about this? Can you give me his or her contact information? I'm an Information Technology (Systems Analysis) major in my Junior year at Oregon Tech, and I can tell you that if I were to give a response like this, I'd have my head handed to me.

    Even if a very small minority of people are using IE 9, your cavalier attitude about it is unprofessional.
  • LPCLPC Major Grins Posts: 568Registered Users Major grins
    edited April 7, 2011
    Never mind
  • AndyAndy Bicameral New YorkPosts: 60,808Registered Users Major grins
    edited April 7, 2011
    Even if a very small minority of people are using IE 9, your cavalier attitude about it is unprofessional.

    Hello, I'm so sorry that you are upset. I will help. We support IE9, and have since it was officially released. What part of your site isn't working in IE9? http://www.naturalaperture.net I'd love to know, so I can look into the issue.

    20110407-bcp8swgm56sb2hpt6dfux5jphh.jpg
  • AndyAndy Bicameral New YorkPosts: 60,808Registered Users Major grins
    edited April 7, 2011
    LPC wrote: »
    Never mind

    I'm sorry, "never mind" - what? I'd love to help but this post seems to be out of context. Standing by....
  • LPCLPC Major Grins Posts: 568Registered Users Major grins
    edited April 7, 2011
    Andy wrote: »
    I'm sorry, "never mind" - what? I'd love to help but this post seems to be out of context. Standing by....

    I deleted my earlier response. Other than some minor cosmetic details when uploading I have no issues whatsover with IE9 - I was just sharing that with the student who posted before me but decided it wasn't neccesary so removed what I had written. Having said that I am now keen to see what problems he is having so will stay tuned :D
  • naturalaperturenaturalaperture Beginner grinner Posts: 9Registered Users Beginner grinner
    edited April 7, 2011
    Hello LPC. I am a SHE, actually. Not all IT majors and photographers are men, as is so often assumed.

    When I load the galleries in IE9, the larger picture that is supposed to be on the right is all the way down on the bottom. I haven't touched anything. I haven't edited my site since spring break, and I just installed IE9 last night. I haven't changed any settings in IE since I had version 8. (The Google Checkout "Add To Cart" buttons have all disappeared as well, but that's a Google issue.)

    Here, it looks like this:
    See all the empty space on the right and the larger picture down on the bottom? That's my issue. Since you're so smart, LPC would you mind telling me how to fix it? I don't know how because I don't use IE.

    Capture-1.jpg
  • AndyAndy Bicameral New YorkPosts: 60,808Registered Users Major grins
    edited April 7, 2011
    I am a SHE, thanks. Not all IT majors and photographers are men.

    When I load the galleries in IE9, the larger picture that is supposed to be on the right is all the way down on the bottom. I haven't touched anything. I haven't edited my site since spring break, and I just installed IE9 last night. I haven't changed any settings in IE since I had version 8.

    Here, it looks like this:
    See all the empty space on the right and the larger picture down on the bottom? That's my issue. Since you're so smart, LPC would you mind telling me how to fix it? I don't know how because I don't use IE.

    Capture-1.jpg
    Hi, I can't replicate this behavior. Can you try resetting your browser zoom to default, and also double checking to make sure you haven't raised the dpi of your system?
  • naturalaperturenaturalaperture Beginner grinner Posts: 9Registered Users Beginner grinner
    edited April 7, 2011
    Apparently you can replicate it by maximizing the browser.
  • naturalaperturenaturalaperture Beginner grinner Posts: 9Registered Users Beginner grinner
    edited April 7, 2011
    The zoom was set at 99%, and there isn't a default option. I changed it to 100%, and it was fine. I reloaded the page, and it went back to the way it was. My resolution is 1440x900, which is the recommended resolution for the widescreen monitors I have.

    Could this have something to do with it being stretchy? Should I try turning that off?
  • AndyAndy Bicameral New YorkPosts: 60,808Registered Users Major grins
    edited April 7, 2011
    No, it's not because of stretchy - I have my Win7 IE9 set to 1440x900 and I can't replicate :(

    20110407-e4skmsjj36c62h89yiapih5ryh.jpg

    I've also tried IE9 32bit and IE9 64bit, no issue. Your screen shot is a smaller browser window than 1440 wide. Can you shut, reopen IE9, try it fully maximized and then make the window smaller - what happens? Are you running any toolbars or sidebars? Can I see a full screenshot of your entire screen? Thanks.
  • naturalaperturenaturalaperture Beginner grinner Posts: 9Registered Users Beginner grinner
    edited April 7, 2011
    It is because I had "stretchy" turned on. I just turned it off, and the larger picture is back on the side where it should be, even with the window maximized. So, the stretchy feature doesn't play nice with IE9 when the browser window is maximized to fit a 19" widescreen monitor. It works in every single other browser-- Opera, Chrome, Firefox, even IE 8 and 6.

    Just saw your last post.... sure. I do have a Google sidebar on that monitor, so I'll try the other one.
  • AndyAndy Bicameral New YorkPosts: 60,808Registered Users Major grins
    edited April 7, 2011
    It is because I had "stretchy" turned on. I just turned it off, and the larger picture is back on the side where it should be, even with the window maximized. So, the stretchy feature doesn't play nice with IE9 when the browser window is maximized to fit a 19" widescreen monitor. It works in every single other browser-- Opera, Chrome, Firefox, even IE 8 and 6.

    Hi, It may be that way for you, but we cannot replicate it here so I can't say that it's something that is a bug. I really want to help, it should work just fine with stretchy at all resolutions (I've used many in testing). Can I again ask for a full screen shot of your IE? Thanks. Also what OS are you running? Thanks.
  • naturalaperturenaturalaperture Beginner grinner Posts: 9Registered Users Beginner grinner
    edited April 7, 2011
    OK, here it is on the monitor (same size and brand as the other one) that does not have the Google sidebar or anything else. Oh, and my OS is Windows 7 Professional, 64-bit.

    Untitled-1.jpg
  • AndyAndy Bicameral New YorkPosts: 60,808Registered Users Major grins
    edited April 7, 2011
    Here's IE9 stretchy going back and forth to as big as 2560x1920. We'll continue to look at this, I suspect you have something set in IE9 that I don't... trying to figure out what that could be.

    http://screencast.com/t/mEB6du7nCl5S
  • AndyAndy Bicameral New YorkPosts: 60,808Registered Users Major grins
    edited April 7, 2011
    OK, here it is on the monitor (same size and brand as the other one) that does not have the Google sidebar or anything else.

    Can I see what the google sidebar looks like please?
  • naturalaperturenaturalaperture Beginner grinner Posts: 9Registered Users Beginner grinner
    edited April 7, 2011
    Ok... the Google sidebar is that vertical strip that's on the left side of the right monitor.

    I just spoke to my boyfriend about this (Senior Java Developer and resident tech guru), and he said it's probably a bug in IE. I'll poke around in my IE settings, though. If I don't find anything within 10 minutes, I'm going to finish my breakfast and get my homework done, because I'd really like to have time for the tulip festival this week.

    I guess if you can't replicate it and neither can anyone else, that's a good thing and it's not on your end or Microsoft's. It's odd that it's doing that for me, though. I only use IE to check browser compatibility. I hate IE.

    Untitled-1-1.jpg
  • naturalaperturenaturalaperture Beginner grinner Posts: 9Registered Users Beginner grinner
    edited April 7, 2011
    Got it. I reset all of IE's settings to default. I find this interesting, since I don't use IE except to check compatibility and don't care enough about it to change any settings. I may have changed something at some point, but nothing so major that it should do that. Reseting to default also fixed a font size issue on my Blogger blog with the menus. Very strange.

    Thank you for your help. You don't need to tell us not to use IE... you need to tell the rest of the world. I did some searching last night and found quite a few unhappy developers.

    capture-2.jpg
  • LPCLPC Major Grins Posts: 568Registered Users Major grins
    edited April 7, 2011
    Hello LPC. I am a SHE, actually. Not all IT majors and photographers are men, as is so often assumed.

    Well, I'm glad your boyfriend helped you fix it thumb.gif
  • gabphotogabphoto Beginner grinner Posts: 1Registered Users Beginner grinner
    edited February 24, 2012
    I had the same problem
    the reset did make it work we still do not kno exactly wich seting is it that makes the photo display below Thank you for the help
  • AndyAndy Bicameral New YorkPosts: 60,808Registered Users Major grins
    edited February 24, 2012
    gabphoto wrote: »
    the reset did make it work we still do not kno exactly wich seting is it that makes the photo display below Thank you for the help

    If your system zoom is at greater than 100% that will cause this.
  • Digital NinjaDigital Ninja Big grins Posts: 13Registered Users Big grins
    edited October 27, 2012
    Hi

    I am actually experiencing the same problem with IE9 (All others browsers work fine)
    Have tried all the suggestions above with no love :(

    Has any tracked down a likely reason for this 'gallery bug' issue

    Specs

    IE9 - running at defaults (Zoom 100% Etc)
    Display size: 1920x1080.


    Thanks in advance for any help

    Shannon :D
  • rainforest1155rainforest1155 SmugMug Support Hero Posts: 4,416Registered Users Major grins
    edited October 28, 2012
    Shannon,
    What font size do you have set in your Windows control panel > appearance > display section? For the gallery to properly display in Internet Explorer, you may have to set that to 100%.
    After changing the setting, the browser zoom may revert itself to something else again - so double check that it's still at 100%.

    If you don't wish to change that font setting, you could use a different browser instead as the issue is Internet Explorer specific. At this point SmugMug only supports 100% for the font and zoom setting.
    Sebastian
    SmugMug Support Hero

    look on the bright side
    http://www.SebastianHosche.com
Sign In or Register to comment.