Options

uh oh! How do I send my clients links to their unlisted galleries?

spider-tspider-t Registered Users Posts: 443 Major grins
edited August 9, 2013 in SmugMug Customization
Something is not working for me.

I have to send a client their photos that are in an unlisted gallery. I grabbed the url at the top of the page when I'm looking at the gallery logged in as I always do. But she says she can't see the pictures and ends up at my home page. I tried this out on a browser where I am not logged in and sure enough, I can't see the pictures either.

Is there someplace new I should be getting my links from in the new design?

Here's the link I was sending:
http://trishtunney.smugmug.com/Downloads/NXP-July-2013/n-j8b4V/i-RDLhcVF

When I'm logged in and I enter this url, I get to the gallery I'd expect.

Help please!!!

thanks,
Trish

Comments

  • Options
    aschendelaschendel Registered Users Posts: 283 Major grins
    edited August 9, 2013
    Try right-clicking on the gallery when you are viewing the level above it and copy the link from there, see if that works.

    Andy
  • Options
    spider-tspider-t Registered Users Posts: 443 Major grins
    edited August 9, 2013
    spider-t wrote: »
    Something is not working for me.

    I have to send a client their photos that are in an unlisted gallery. I grabbed the url at the top of the page when I'm looking at the gallery logged in as I always do. But she says she can't see the pictures and ends up at my home page. I tried this out on a browser where I am not logged in and sure enough, I can't see the pictures either.

    Is there someplace new I should be getting my links from in the new design?

    Here's the link I was sending:
    http://trishtunney.smugmug.com/Downloads/NXP-July-2013/n-j8b4V/i-RDLhcVF

    When I'm logged in and I enter this url, I get to the gallery I'd expect.

    Help please!!!

    thanks,
    Trish


    To add info to the question:

    Last month when I grabbed the link at the top to the same gallery for my client using the old design, this is what the link looked like:
    http://www.trishtunney.com/Downloads/NXP-July-2013/30512043_R96Djn
    And this link actually gets to the pictures when I'm not logged in.
  • Options
    spider-tspider-t Registered Users Posts: 443 Major grins
    edited August 9, 2013
    aschendel wrote: »
    Try right-clicking on the gallery when you are viewing the level above it and copy the link from there, see if that works.

    Andy

    Hi Andy, Thanks. Tried it but that didn't work either. I just get the link that is view-able when I'm logged in. This is so weird. How are people delivering their pictures? Am I the only one who shares unlisted galleries? I feel like I must be missing something obvious.

    I have a new gallery that I also have to share. One that was created while in the new smugmug design. And when I couldn't get that gallery's url to share with my client, I went back to viewing legacy smugmug to get the URL. But that gallery is not in my legacy smugmug view. So gallery creation and location must be handled in a totally different way in the new design.

    Trish
  • Options
    denisegoldbergdenisegoldberg Administrators Posts: 14,268 moderator
    edited August 9, 2013
    My unlisted galleries are accessible when I am not logged in, but my site is on the new smugmug. It looks like your published site is on legacy smugmug. Did you create the gallery in legacy smug? If you created it in new smug it might be worth creating it again in legacy smugmug and then grabbing the link from there. I might be imagining things but it looks to me like the funky characters in the URL are different in new smug.

    --- Denise
  • Options
    spider-tspider-t Registered Users Posts: 443 Major grins
    edited August 9, 2013
    So you're saying maybe when I fully commit the design change my unlisted galleries might start working again. That sounds hopeful. I wish I didn't have to do deliveries in the middle of doing the work of coming up with a re-designed site I'm happy with.

    Maybe someone has a work-around for me so I don't have to duplicate my work until I have a chance to get back to the site design task?

    thanks!!
    Trish
    My unlisted galleries are accessible when I am not logged in, but my site is on the new smugmug. It looks like your published site is on legacy smugmug. Did you create the gallery in legacy smug? If you created it in new smug it might be worth creating it again in legacy smugmug and then grabbing the link from there. I might be imagining things but it looks to me like the funky characters in the URL are different in new smug.

    --- Denise
  • Options
    mklabovemklabove Registered Users Posts: 18 Big grins
    edited August 9, 2013
    Spider-t

    I might be seeing different behavior, since I've unveiled the new smug, but try this - When logged in, open the unlisted gallery, click on any photo, and then at the bottom of the page click on the Share options. There you can choose 'Get a link'. Then click on Gallery links, and copy the one you want. I don't know if that will be different from what you're copying from the address bar, but . . .

    Hope that works.

    Keith
  • Options
    denisegoldbergdenisegoldberg Administrators Posts: 14,268 moderator
    edited August 9, 2013
    spider-t wrote: »
    So you're saying maybe when I fully commit the design change my unlisted galleries might start working again. That sounds hopeful. I wish I didn't have to do deliveries in the middle of doing the work of coming up with a re-designed site I'm happy with.
    I just checked again, and unlisted galleries definitely work in the new smug but the gallery URL looks very different from the one in the old smug.

    This is a really long shot but maybe you will be able to construct the URL for legacy smug.

    I've checked galleries created in both new and legacy smug. The URLs shown in the new smug are different than the URLs shown in the old, but the old album id and key are visible in the page source. This is the URL from the new smug for an unlisted gallery that I created in legacy smug - http://www.denisegoldberg.com/Other/Evins-tulips/n-bDQgQ. If I do a view source on the page I find this:
    var galleryView = new Y.SM.Gallery.SmugMugView({
        galleryType: "album",
        galleryRequestData: {"galleryType":"album","albumId":"29428382","albumKey":"khxjwL","nodeId":"bDQgQ"},
    
    If I construct the gallery URL as http://www.denisegoldberg.com/Other/Evins-tulips/29428382_khxjwL]http://www.denisegoldberg.com/Other/Evins-tulips/29428382_khxjwL (that is, I replaced n-bDQgQ with 29428382_khxjwL) I can still reach the gallery. The first number in the URL is the albumId and the funky letters are the albumKey.

    That's probably worth a try.

    --- Denise
  • Options
    spider-tspider-t Registered Users Posts: 443 Major grins
    edited August 9, 2013
    Thanks for the idea Keith. Didn't work for me. Under the sharing options, Get a Link is grayed out. When I hover it says 'this sharing option is disabled because gallery is marked as "private"'.
    mklabove wrote: »
    Spider-t

    I might be seeing different behavior, since I've unveiled the new smug, but try this - When logged in, open the unlisted gallery, click on any photo, and then at the bottom of the page click on the Share options. There you can choose 'Get a link'. Then click on Gallery links, and copy the one you want. I don't know if that will be different from what you're copying from the address bar, but . . .

    Hope that works.

    Keith
  • Options
    dereksurfsdereksurfs Registered Users Posts: 286 Major grins
    edited August 9, 2013
    I just checked again, and unlisted galleries definitely work in the new smug but the gallery URL looks very different from the one in the old smug.

    --- Denise

    Yes, this seems to be more commonly the case. Most folks don't understand that there are differences with the new URLs. The old URLs no longer work the same, especially for UNLISTED galleries. But unlisted galleries are definitely visible in the new SM.

    Here is one of mine: http://landandseaphoto.smugmug.com/Navigation/About-the-photographer/n-Kq8pJ

    The key is the copy the new URL correctly *including* the case. SM is aware of this case sensitivity issue and is working on a few possible fixes. But for now get the URL correct and it will work.
  • Options
    denisegoldbergdenisegoldberg Administrators Posts: 14,268 moderator
    edited August 9, 2013
    spider-t wrote: »
    Thanks for the idea Keith. Didn't work for me. Under the sharing options, Get a Link is grayed out. When I hover it says 'this sharing option is disabled because gallery is marked as "private"'.
    I just updated the post before this one. I think you can reconstruct the URL to work in old smug (but it's a guess since I can't test my gallery in old smug). I think it's worth a try though.

    --- Denise
  • Options
    spider-tspider-t Registered Users Posts: 443 Major grins
    edited August 9, 2013
    hi denise, i appreciate your post and i find i don't understand it on first glance. but for now, i have a link to the legacy gallery i needed because i remembered i had grabbed it before i switched. i'll study your post more closely the next time i run into needing to get to another unlisted gallery. for now i'm trying to deliver a gallery i made in the new design. which also does not seem to have a public url.

    thanks,
    trish
    I just checked again, and unlisted galleries definitely work in the new smug but the gallery URL looks very different from the one in the old smug.

    This is a really long shot but maybe you will be able to construct the URL for legacy smug.

    I've checked galleries created in both new and legacy smug. The URLs shown in the new smug are different than the URLs shown in the old, but the old album id and key are visible in the page source. This is the URL from the new smug for an unlisted gallery that I created in legacy smug - http://www.denisegoldberg.com/Other/Evins-tulips/n-bDQgQ. If I do a view source on the page I find this:
    var galleryView = new Y.SM.Gallery.SmugMugView({
        galleryType: "album",
        galleryRequestData: {"galleryType":"album","albumId":"29428382","albumKey":"khxjwL","nodeId":"bDQgQ"},
    
    If I construct the gallery URL as http://www.denisegoldberg.com/Other/Evins-tulips/29428382_khxjwL]http://www.denisegoldberg.com/Other/Evins-tulips/29428382_khxjwL (that is, I replaced n-bDQgQ with 29428382_khxjwL) I can still reach the gallery. The first number in the URL is the albumId and the funky letters are the albumKey.

    That's probably worth a try.

    --- Denise
  • Options
    pworm14pworm14 Registered Users Posts: 17 Big grins
    edited August 9, 2013
    Spider-t, Did you try creating a "ShareGroup" for the gallery. That's what I always used on my old site. I don't recall exactly where the option is on the legacy sites, but on the new sites its in under Account Settings/Discovery/Sharegroups.
  • Options
    spider-tspider-t Registered Users Posts: 443 Major grins
    edited August 9, 2013
    Thanks for the reply pworm. I have never used the share group feature before. I have delivered maybe hundreds of galleries via URL over the years and not needed that feature. But maybe it's something I'll need to learn about with the new design. Thanks for the idea.


    Trish

    pworm14 wrote: »
    Spider-t, Did you try creating a "ShareGroup" for the gallery. That's what I always used on my old site. I don't recall exactly where the option is on the legacy sites, but on the new sites its in under Account Settings/Discovery/Sharegroups.
  • Options
    pworm14pworm14 Registered Users Posts: 17 Big grins
    edited August 9, 2013
    spider-t wrote: »
    Thanks for the reply pworm. I have never used the share group feature before. I have delivered maybe hundreds of galleries via URL over the years and not needed that feature. But maybe it's something I'll need to learn about with the new design. Thanks for the idea.


    Trish

    You're welcome. Not quite as easy as copy/paste the URL, but it does work. Good luck!
Sign In or Register to comment.