Home page anomalies in different browsers

W.W. WebsterW.W. Webster Happily mirrorfreeNew ZealandPosts: 3,194Registered Users Major grins
edited January 27, 2016 in Bug Reporting
For no particular reason, I happened to log out of my SmugMug site and took a look at my home page as a visitor would see it - initially in Chrome 47.0.2526.111 (on Mac).

Shock, horror, the home page background image was shoved up through the top of the window, apparently to align its bottom edge with the bottom of the content in my vertical nav bar. Refreshing the page did not fix it. It looks like this -

<cringe>

i-JNhS6HD.jpg

</cringe>

So I took a look in Safari 9.0.3. Now the background image was displayed correctly, but the vertical nav bar had been nudged up so the top of my logo was chopped off (refreshing didn't fix this either) -

<cringe>

i-QHbVPdR.jpg

</cringe>

At this stage, I was getting really anxious. So I took a look in Firefox 43.0.4 and was relieved to see the page displayed correctly -

i-25t2WFT.jpg

What is happening? I'm very embarrassed at the mess it appears many of my visitors have been seeing, likely to have been for a very long time.

My home page uses bog-standard SmugMug functions without any hacks that I'm aware of. I haven't looked at any other pages or used any other browsers so the possible extent of these problems doesn't bear thinking about.

What do i do now? I could lodge a support call but I'd just be told to clear my cookies and asked if there was anything else they could do for me today - been there, done that. Anyone else having this problem?

Comments

  • AllenAllen "tweak 'til it squeaks" St. Louis, MoPosts: 9,537Registered Users Major grins
    edited January 26, 2016
    Chrome on a windows PC here shows the bottom of the photo at "2015 in images".
    Go full screen and it's okay. Reload full screen page and it stops at copyright.
    Al - Just a volunteer here having fun
    My Website | My Blog
  • W.W. WebsterW.W. Webster Happily mirrorfree New ZealandPosts: 3,194Registered Users Major grins
    edited January 26, 2016
    Allen wrote: »
    Chrome on a windows PC here shows the bottom of the photo at "2015 in images".
    Go full screen and it's okay. Reload full screen page and it stops at copyright.
    Thanks Allen. Weird.
  • leftquarkleftquark SmugMug Product Team Posts: 3,466Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee
    edited January 27, 2016
    It's strange, when I refresh your page a few times I get a mix of it looking like the screenshot and it looking fine. I do see that your background is in a gallery limited to X3, and the browser is much larger than the 1600px x 1200px limitation of the x3 image. It may be that there's a bug in chrome in that it is having issues expanding the x3 image to fill the screen like we're telling it to. you could try setting the gallery to Original size and see if it fixes it.
    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • W.W. WebsterW.W. Webster Happily mirrorfree New ZealandPosts: 3,194Registered Users Major grins
    edited January 27, 2016
    leftquark wrote: »
    I do see that your background is in a gallery limited to X3, and the browser is much larger than the 1600px x 1200px limitation of the x3 image.
    Where do I set that Aaron? The original is 2560 x 1600.
  • leftquarkleftquark SmugMug Product Team Posts: 3,466Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee
    edited January 27, 2016
    Where do I set that Aaron,? The original is 2560 x 1600.

    It'd be in the gallery settings of the gallery housing the background image. What I've done for my backgrounds is to create a separate gallery called 'Backgrounds' and have it set to Originals. Then I upload a copy of the file (since collecting won't work) to the Backgrounds, and use these high quality images as backgrounds.
    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • W.W. WebsterW.W. Webster Happily mirrorfree New ZealandPosts: 3,194Registered Users Major grins
    edited January 27, 2016
    leftquark wrote: »
    It'd be in the gallery settings of the gallery housing the background image.
    Can you give me another clue? I couldn't see it there!
    leftquark wrote: »
    What I've done for my backgrounds is to create a separate gallery called 'Backgrounds' and have it set to Originals. Then I upload a copy of the file (since collecting won't work) to the Backgrounds, and use these high quality images as backgrounds.
    That's exactly what I've (thought I've) done.
  • leftquarkleftquark SmugMug Product Team Posts: 3,466Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee
    edited January 27, 2016
    Can you give me another clue? I couldn't see it there!

    That's exactly what I've (thought I've) done.

    If you can point me to the gallery (feel free to send me a private message) I can double check the settings. Under Gallery Settings, it'd be under "Photo Protection" and it's "Max Display Size". You'd want it set to "Original" and not "X3Large".

    Another issue that I noticed is that your background is set in the Theme, to apply to the homepage only, and it's set to "Fit" instead of "Fill". So it actually appears to be doing what it should: fit the background to the maximum size it can be, without stretching it to fill the entire screen (so it's fitting it to the width, and leaving room on the bottom so it doesn't stretch or zoom in). If you set it to "Fill" it should fill up the entire screen. This would be in Customize -> Content and Design -> Theme tab -> Your Theme -> Advanced tab.
    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • W.W. WebsterW.W. Webster Happily mirrorfree New ZealandPosts: 3,194Registered Users Major grins
    edited January 27, 2016
    Gallery Settings >Photo Protection > Maximum Display Size was already set to 'Original'. Where did you see x3? What else should I have set?
  • W.W. WebsterW.W. Webster Happily mirrorfree New ZealandPosts: 3,194Registered Users Major grins
    edited January 27, 2016
  • W.W. WebsterW.W. Webster Happily mirrorfree New ZealandPosts: 3,194Registered Users Major grins
    edited January 27, 2016
    leftquark wrote: »
    Another issue that I noticed is that your background is set in the Theme, to apply to the homepage only, and it's set to "Fit" instead of "Fill". So it actually appears to be doing what it should: fit the background to the maximum size it can be, without stretching it to fill the entire screen (so it's fitting it to the width, and leaving room on the bottom so it doesn't stretch or zoom in). If you set it to "Fill" it should fill up the entire screen. This would be in Customize -> Content and Design -> Theme tab -> Your Theme -> Advanced tab.
    I see this is set to "Fill". I presume you have done that if it wasn't already set that way. However the problem seems to persist.
  • leftquarkleftquark SmugMug Product Team Posts: 3,466Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee
    edited January 27, 2016
    I see this is set to "Fill". I presume you have done that if it wasn't already set that way. However the problem seems to persist.

    Yep - I was hoping it would fix it, but alas, it still persists. I can't, for the life of me, figure out why 1/2 the time chrome decides to load it properly, and 1/2 the time it loads the image halfway up.
    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • W.W. WebsterW.W. Webster Happily mirrorfree New ZealandPosts: 3,194Registered Users Major grins
    edited January 27, 2016
    Mmm. Is the (different) issue on the home page under Safari related, do you think?
  • leftquarkleftquark SmugMug Product Team Posts: 3,466Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee
    edited January 27, 2016
    Since it's better practice to set the background using the "Background" tab in the Customizer, I removed the Background from your theme (in its Advanced Settings) and set a Homepage background to the same image. It appears to have fixed the problem in Chrome, at least on the 12 refreshes that I performed! I couldn't duplicate your issue in Safari but I did notice the page loads much better (I don't see the background jump, like it did prior to making the change), so I'm hoping its fixed for you as well. Let me know if there's other issues or if I set the background incorrectly.
    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • W.W. WebsterW.W. Webster Happily mirrorfree New ZealandPosts: 3,194Registered Users Major grins
    edited January 27, 2016
    Voilà! Thanks a lot, Aaron. At a quick glance that seems to have fixed both problems - in Chrome and Safari.

    I'm just a simple guy and I didn't realise I was using an inferior practice! eek7.gif

    I'm very grateful for your assistance. Now get to bed! :D
  • leftquarkleftquark SmugMug Product Team Posts: 3,466Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee
    edited January 27, 2016
    I'm just a simple guy and I didn't realise I was using an inferior practice! eek7.gif
    Now now - don't discredit yourself! You took the time to play and familiarize yourself with a tool and you took advantage of one way that it was intended to be used. Not your fault that there's multiple ways to do the same thing. Ideally there'd be only 1 way to set a background, and that'd be from the "Background" tab, but in order for Theme's to have graphics (textures, images, etc) and to maintain compatibility with Legacy, the "Theme" needed its own background option.

    The whole issue gets more complex when we start talking about galleries and folders that are custom ("Just this _____"). We're in the process of pushing out an update that will clarify the preference in which background is used.

    #1 will have higher preference than #2, etc, so if we see a background set we'll use #1, if not we look at #2, etc....
    1) One-off Gallery Design ("Background" tab)
    2) One-off Gallery Theme (set in the Theme's advanced settings)
    3) All Galleries Design ("Background" tab)
    4) All Galleries Theme (set in the Theme's advanced settings)
    5) Entire Site Design ("Background" tab)
    6) Entire Site Theme (set in the Theme's advanced settings)
    (list also applies to Folders)
    Now get to bed! :D
    If I went to bed before 2am when would I have any time to edit my photos?! :)

    Glad we could get this working!
    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • W.W. WebsterW.W. Webster Happily mirrorfree New ZealandPosts: 3,194Registered Users Major grins
    edited January 27, 2016
    leftquark wrote: »
    The whole issue gets more complex ...
    I fully understand. There are many layers to new SmugMug and some things can become a deep dive.
    leftquark wrote: »
    We're in the process of pushing out an update that will clarify the preference in which background is used ...
    That will be very helpful, as it's not as though it's everyday functionality so it doesn't become entirely intuitive. With any of the more detailed functions, it's not always apparent exactly where you are in the overall context.
    leftquark wrote: »
    If I went to bed before 2am when would I have any time to edit my photos?! :)
    Is that what you call work/life balance?
    leftquark wrote: »
    Glad we could get this working!
    Thanks again.
Sign In or Register to comment.