Everything set to 'Private' access only; unable to change to be 'Unlisted' or 'Public'

landejolandejo San Francisco, CAPosts: 3Registered Users Beginner grinner
For the benefit of other former Phanfarians (?) who might've run into this as well:

All of my Phanfare content has migrated over to my SmugMug account. Unfortunately, everything is set to 'Private' ("Accessible only by me") at an *Account* level, and no matter how many times I set folders or galleries to be 'Unlisted', they remain 'Private'.

The SmugMug folks are working on a resolution but haven't yet found/implemented a fix.

/Jason

Comments

  • BHunsakerBHunsaker Vancouver, WA, USAPosts: 9Registered Users Big grins
    I had a similar problem that was intertwined with a desire for a site-wide password.

    After stating "they were working on it", I got a reply saying I should go to the URL
    ---
    https://secure.smugmug.com/settings/?nick=#section=privacy

    In the "Site Access" drop-down menu, choose a different setting from the one you have currently.

    Click "Save and Exit."
    ---

    My privacy section has no such "Site Access" drop down, so eventually I received this comment:

    ---
    I had to clear out the setting here on our end to fix this. Please try adding the password again and let me know if it works this time.
    ---

    This fixed it. My final change was to use the bulk gallery settings to set the visibility to "Public (Anyone)". Since my site has a site-wide password, things aren't truly "public", but rather can be viewed by only those with the password. Of course I need to figure out if things are treated differently if you are logged into Smugmug or not. What exactly does the "Access" setting do and how does it interact with the "Visibility" and site-wide password settings...
  • landejolandejo San Francisco, CAPosts: 3Registered Users Beginner grinner
    edited April 19, 2017
    Thanks @BHunsaker . I do have that 'Site Access' drop down on my account, and it's set to 'Anyone'. Turns out, like they'd told you, I needed to change it to be a different setting, save-and-exit, then go back and change it back to be 'Anyone'. Now it works.

    Thanks!!

    /Jas
  • mwac_ndmwac_nd TexasPosts: 7Registered Users Big grins
    Hello. I'm having the same problem. (Sorry for the duplicate thread - I *swear* I looked for answers here first before posting, but it was late and I was frustrated!)

    I don't have the "Site Access" drop down on my account either. I'll contact support. Thanks for the clues!
  • UserNameUserNameUserNameUserName USAPosts: 2Registered Users Beginner grinner
    1) I complained to Smugmug about the default setting to Private when they migrated our photos. All mine were Published in Phanfare. I spent hours setting them back to public inn Smugmug. Over 100 Folders and 2,200Galleries with 98,000 Images. They said they want to err on the side of saftey.

    2) More than 45,000 of my photos were scanned from sildes and negatives where the date of the image is meaninless. I automatically named file using the format "yyyy-mm-dd-xxx EVENT Name" ['1973-11-15-001 The Big Day', '1973-11-15-002 The Big Day', '1973-11-15-003 The Big Day', etc]. In Smugmug I many more hours changing their date decending order to sort by filename.

    3) SmugMuf never even considered giving us the option of a theme like we had in Phanfare which was the reason I was with PhanFare and not SmugMug in the first place.

    All they tell me now is how they at Smugmug want to help me celbrate their photos.
  • KarinaExPhanfareKarinaExPhanfare Melbourne, AustraliaPosts: 93Registered Users Big grins

    I followed the tips here to change the main "site access" - but still seem to have to click on each and every folder and gallery to set it specifically to either public or unlisted.

    Now also noticing that every single folder where I fixed its privacy setting to either public or unlisted or "only me" - has again changed over night.

    I am left baffled !

  • MikeLaurelMikeLaurel Southern CaliforniaPosts: 67Registered Users Big grins

    I'm finding security settings on SmugMug to be quite problematic. Most content I want to lock down, but I make a few things public. By "lock down" I mean Unlisted. If I make things private, I can't share with anyone.

    The problem I keep running into is having my unlisted and password protected photos appear on the recent photos content block of my main page. I've contacted support and they said not to make galleries Smug Mug searchable...but it still shows photos from galleries with that option off. Yes, if the gallery is password protected and you click on a photo, you are asked for the password to see all the photos that the system already showed you in the content block without requiring a password. Seems kind of worthless. And if it's showing photos from an unlisted gallery and click on it, you get access to the gallery, and possibly, through breadcrumbs, access to a whole bunch of other stuff that's unlisted.

    I'm about at the point of just getting rid of the recent photos content block, since it that content block wasn't built with security in mind. I frequently find it showing photos that shouldn't be there and not showing public photos that I would hope that it does show.

  • AllenAllen "tweak 'til it squeaks" St. Louis, MoPosts: 9,459Registered Users Major grins

    Make sure you are not logged when viewing. When logged in you will see everything.

    Al - Just a volunteer here having fun
    My Website | My Blog
  • MikeLaurelMikeLaurel Southern CaliforniaPosts: 67Registered Users Big grins

    @Allen said:
    Make sure you are not logged when viewing. When logged in you will see everything.

    I've gone to a different web browser where I'm not logged in and also cleared the cache; I still seem to get unpredictable behavior.

  • AllenAllen "tweak 'til it squeaks" St. Louis, MoPosts: 9,459Registered Users Major grins

    If clearing cache doesn't fix problem the next step is clearing Smugmug cookies.

    Al - Just a volunteer here having fun
    My Website | My Blog
  • AllenAllen "tweak 'til it squeaks" St. Louis, MoPosts: 9,459Registered Users Major grins

    BTW, the new more convenient way to handle security is set it at a folder level so it will flow down to children. No need to assign every child below as they would inherit security from above. Perhaps you've set upper levels security and it's flowing down which might interfere with any lower settings?

    Al - Just a volunteer here having fun
    My Website | My Blog
  • MikeLaurelMikeLaurel Southern CaliforniaPosts: 67Registered Users Big grins

    @Allen said:
    If clearing cache doesn't fix problem the next step is clearing Smugmug cookies.

    I cleared everything: cookies, cache, etc. It didn't solve the problem.

    @Allen said:
    BTW, the new more convenient way to handle security is set it at a folder level so it will flow down to children. No need to assign every child below as they would inherit security from above. Perhaps you've set upper levels security and it's flowing down which might interfere with any lower settings?

    I'm using inheritance on the folders. They're set up like this:
    1. Top folder: Public Visibility, People with Password Access
    2. Second folder: Public Visibility, People with Password (inherited) Access
    3. Gallery: Public Visibility, People with Password (inherited) Access

    I finally figured it out. The gallery contains collected photos. The gallery containing the source photos was set up like this:
    1. Top folder: Unlisted Visibility, Anyone with a Link Access
    2. Second folder: Unlisted Visibility, Anyone with a Link Access
    3. Gallery: Public Visibility, Anyone Access. It should have been set to Unlisted/anyone with a link. When I changed the setting, the problem went away.

    I've run into that pain previously, but the odd thing about this time is that if I clicked on the link, it was trying to take me to the gallery containing the collected photos, even though the permissions from elsewhere were letting the images be shown in recent photos.

    Still, the recent photos option seems broken. It should only show pictures that you could see with your access and without having to guess unlisted URLs (i.e., public from the top down, or if I've given a password it could include things I could see with that password. And I have a public album whose photos it doesn't show. Go figure.

    I find the SmugMug security to be troublesome and very time consuming. So far, I've probably spent at least an hour trying to figure out this problem with one gallery. With Phanfare, it just worked.

Sign In or Register to comment.