issues adding back Client Area

PierreBPierreB Registered Users Posts: 9 Big grins

Hiya, I'm having an issue getting the Client area back up and running, and making it work.
Here is my setup:

My landing page is done on WordPress, as is the Contact page.

The Smugmug portion are the portfolio and gallerie pages. The URL used for these is:

So in essence, the person who setup my site is using for Smugmug.

I haven't done the WordPress portion yet, I simply added the Client area in my Smugmug navigation bar, so you can see it only when you click on something in the "photos.pierreb....". Figure I'd get it up and running here before even venturing into WordPress.

I setup two galleries as tests, have them set to viewable to anyone with link and are password protected.

The issue I have is when I am logged out of Smugmug admin, I click on say Portfolio and then on Clients and I get the admin login page for Smugmug. I have seen a single page where a user can input their password and get their photos, but this is not happening for me, and after hours of trying to tweak, read, watch tutorials,... not working :(

Any input?


"If your picture isn't good enough, you're not close enough."
- Robert Capa


  • leftquarkleftquark Registered Users, Retired Mod Posts: 3,784 Many Grins

    The "Client Area" uses a private sharing feature which allows you to share specific galleries with "People I Choose". You put in their email address and they receive an invitation where they create a free SmugMug Guest Account. They login to the Client Area using that Guest Account and will be shown the photos you've shared with them. You can set "People I choose" in the "Security and Sharing" section of the Gallery Settings, under "Access". For more information see here:

    If you just want a gallery password, set the Access to "People with Password" and make sure you share the password with your clients.

    dGrin Afficionado
    Former SmugMug Product Team
    aaron AT aaronmphotography DOT com
    My SmugMug CSS Customizations website:
Sign In or Register to comment.