Why don't I have access to Markdown and other editing features?

camnercamner Beginner grinnerPosts: 29Registered Users Big grins
edited August 14, 2017 in Dgrin Forum Support
I was attempting my first post and could not for the life of me get Markdown to work...Looking at one of the early entries in this post: https://dgrin.com/discussion/260088/help-for-newbie#latest I see that there should be a toolbar of icons of available formatting options (links, code, etc) right above the main Discussion posting block. All I have is a dropdown menu of emoticons. I've tried 3 different browsers (Safari, Firefox, Chrome), and I get the same behavior on all of them.

What do I need to do to get access to these tools so I can format my posts appropriately?

And, while I'm at it, is one automatically subscribed to posts one creates, with email notifications, or is there some magic here I'm not aware of?


Thanks!

Comments

  • Hikin' MikeHikin' Mike Walkin' like a Penguin! Atwater, CaPosts: 3,512Registered Users Major grins

    I pretty sure you need more time. I don't know what the magic number (no. of posts) is, but I know new members are limited.

  • camnercamner Beginner grinner Posts: 29Registered Users Big grins
    Thanks a million!

    You know, it sure would save us newbies a lot of time and hair pulling if there were a sticky post at the top of the Dgrin Forum Support forum (maybe in the existing post marked START HERE??) that would give this kind of information. (Yeah, I know you're a volunteer, so I know that you can't make this change yourself!)
  • camnercamner Beginner grinner Posts: 29Registered Users Big grins
    While I have your attention....how about my question re getting email notifications when replies are made to my posts? Is that also something that will automagically appear when I have enough posts to qualify?
  • Hikin' MikeHikin' Mike Walkin' like a Penguin! Atwater, CaPosts: 3,512Registered Users Major grins

    @camner said:
    Thanks a million!



    You know, it sure would save us newbies a lot of time and hair pulling if there were a sticky post at the top of the Dgrin Forum Support forum (maybe in the existing post marked START HERE??) that would give this kind of information. (Yeah, I know you're a volunteer, so I know that you can't make this change yourself!)

    I personally think a new member should have full access, especially posting photos. It is a photo forum. But I do understand about trying to limit spammers. Adding a sticky would help though.

    @camner said:
    While I have your attention....how about my question re getting email notifications when replies are made to my posts? Is that also something that will automagically appear when I have enough posts to qualify?

    No idea. I don't use the e-mail notifications.

  • camnercamner Beginner grinner Posts: 29Registered Users Big grins

    Thanks for your help. I look forward to getting my first badge and enjoying full privileges!

  • RichardRichard Mildly bemused Madrid, SpainPosts: 17,972Administrators, Vanilla Admin moderator

    @camner said:
    While I have your attention....how about my question re getting email notifications when replies are made to my posts? Is that also something that will automagically appear when I have enough posts to qualify?

    Click on the little gear icon that appears in the upper right corner of the header and select Edit Profile, then in the right sidebar select Notification Preferences. There are quite a few options to choose from including notification on reply to your posts.

  • camnercamner Beginner grinner Posts: 29Registered Users Big grins

    Thanks, Richard. That helps.

    OK, so now I have access to Markdown! Woo hoo!

    But, I'm still confused about something...I'd like to put in a code block the following two lines:
    .class1 {color:red;}
    .class2 {background-color:blue;}

    If I use the paragraph dropdown menu and choose "code," I get two back ticks. If I then put the lines above in between the back ticks, this is what happens:
    .class1 {color:red;} .class2 {background-color:blue;}
    This puts the code all on one line, without a line break. Using "return" obviously doesn't work. Using "br" (with the appropriate greater-than/less-than marks that are stripped out!) doesn't work. Putting two or more spaces after the first line doesn't work (I read this technique in a non-SmugMug doc of Markdown)

    How does one put in a line break inside a code block?

  • RichardRichard Mildly bemused Madrid, SpainPosts: 17,972Administrators, Vanilla Admin moderator
    .class1 {color:red;}
    .class2 {background-color:blue;}
    

    I don't use code formatting very often, so there may be some gotcha here, but I just copied the code text from your post and pasted it into this reply. Then I selected both lines and hit the format code button. It seems to have worked.

  • camnercamner Beginner grinner Posts: 29Registered Users Big grins

    Interesting… I did it in the opposite order: I typed in the code, then hit the "cold" button, and copied/pasted the text in between the back text. That didn't work. I'll try it your way and see what happens.

    .class1 {color:red;}
    .class2 {background-color:blue;}
    

    Bingo! Type first, select "code" block second, works like a charm. The other way 'round, not so much.

    Thanks for the help!

  • Hikin' MikeHikin' Mike Walkin' like a Penguin! Atwater, CaPosts: 3,512Registered Users Major grins

    @camner said:
    Interesting… I did it in the opposite order: I typed in the code, then hit the "cold" button, and copied/pasted the text in between the back text. That didn't work. I'll try it your way and see what happens.

    .class1 {color:red;}
    .class2 {background-color:blue;}
    

    Bingo! Type first, select "code" block second, works like a charm. The other way 'round, not so much.

    Thanks for the help!

    I don't use the buttons. I just wrap one single backtick for a single line code and three for multiple lines.

  • camnercamner Beginner grinner Posts: 29Registered Users Big grins

    This ought to be easy, but I can't make it work well. I tried wrapping multiple lines of code in 3 back ticks, and while it all ended up in a code block, the line breaks were not respected. The code block below was wrapped in 3 back ticks (3 in front, 3 in back):

    /* Set the navbar submenu hover background color */ /* Note: .sm-page-widget-18841881 is the id for the 2nd menu on the page-the yearly galleries*/ .sm-page-widget-18841881 .yui3-menu .yui3-menu-children .yui3-menu-item .yui3-menu-label:hover { background: #679966; } /* End setting the navbar submenu hover background color */ /* Change the styling of the gallery menu item links upon hover */ .sm-page-widget-18841881 .sm-page-widget-nav-toplink a:hover { background-color: #679966; }
    No line breaks...grrrr...
    This is what it should look like:
    /* Set the navbar submenu hover background color /
    /
    Note: .sm-page-widget-18841881 is the id for the 2nd menu on the page-the yearly galleries/
    .sm-page-widget-18841881 .yui3-menu .yui3-menu-children .yui3-menu-item .yui3-menu-label:hover {
    background: #679966;
    } /
    End setting the navbar submenu hover background color /
    /
    Change the styling of the gallery menu item links upon hover */
    .sm-page-widget-18841881 .sm-page-widget-nav-toplink a:hover {
    background-color: #679966;
    }

    I am noticing that for some reason, Markdown is stripping out the asterisk in the "close CSS comment" code (asterisk+slash)

    What I did below is to use the "Quote" option in the dropdown menu, and this looks decent.

        /* Set the navbar submenu hover background color */
        /* Note: .sm-page-widget-18841881 is the id for the 2nd menu on the page-the yearly galleries*/
        .sm-page-widget-18841881 .yui3-menu .yui3-menu-children .yui3-menu-item .yui3-menu-label:hover {
          background: #679966;
        } /* End setting the navbar submenu hover background color */    
        /* Change the styling of the gallery menu item links upon hover */
        .sm-page-widget-18841881 .sm-page-widget-nav-toplink a:hover {
          background-color: #679966;
        }
    
Sign In or Register to comment.