Lightroom Plugin Updates (v3.1.5.0): Simultaneous Uploads and Bug Fixes

leftquarkleftquark SmugMug Product TeamPosts: 3,277Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee
edited February 22, 2018 in SmugMug Product News

We've released a new version of our Lightroom plugin with the following updates:

New:
* Simultaneous uploads: speeds uploading by allowing 3 uploads to occur at once.
* Added a "ChangeLog.txt" inside the .lrplugin file (this one's for you @Ferguson)

Updated:
* Bug fixes for Cover Image and Quick Settings
* Added the Slideshow option to Gallery Settings

Simultaneous Uploads:
You can find the option to enable Simultaneous uploads in the Plugin settings:

  • For any given publish action, we’ll do 3 Simultaneous publish/uploads at one time. While one photo is exporting, another photo may be uploading, etc.

Change Log:
Our preferred location for release notes is on the Adobe CC Plugin website, however, since there can be some delay in the version/release notes posted, we'll take an intermediate step and start including a "ChangeLog.txt" file within the contents of the plugin. On a macOS device, you can find this by locating the SmugMug.lrplugin file (easiest way is to go to the LR Plugin Settings, and choose SmugMug and then choose the "Show in Finder" option for a mac) and choosing "Show Package Contents." I'm not quite sure how to do this on Windows.

SmugMug Director of Product / dGrin Afficionado
aaron AT aaronmphotography DOT com
Website: http://www.aaronmphotography.com
My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations

Comments

  • DuaneADuaneA Beginner grinner Posts: 9Registered Users Big grins
    Hey, I think you may have a problem. Since this update, publishing stalls indefinitely after about 12 photos. If I restart LR, I can get another 12 to go, then it stalls again. I have tried re-booting, waiting over-night... same results. Cancel does not work. When I open the Plug-In manager during a stall, the Plug-In manager posts an error message that it is "waiting for Smugmug" and I cannot make plug-in setting changes. ** I DISABLED THE NEW SIMULTANEOUS UPLOAD FEATURE, AND NOW MY UPLOAD IS WORKING **. My internet connection is 60 MB/s up.
  • FergusonFerguson Major grins Posts: 1,219Registered Users Major grins

    @leftquark said:

    • Added a "ChangeLog.txt" inside the .lrplugin file (this one's for you @Ferguson)

    Thank you!

    I'll download and give it a try in a bit.

    • For any given publish action, we’ll do 3 Simultaneous publish/uploads at one time. While one photo is exporting, another photo may be uploading, etc.
    • Our Lightroom plugin typically only publishes one gallery worth of photos in one action. You can go to a different gallery, and publish photos to that gallery - this kicks off a new “action” in Lightroom (which you can see by there being a second action bar in the upper left corner of Lightroom). The second action won’t start until the first action is complete.
    • So if you publish 100 photos from Gallery1, then immediately publish 30 photos photo Gallery2, we’ll upload 3 photos concurrently from Gallery1 until all 100 are uploaded …. then move on to Gallery2 and upload 3 photos at a time until all 30 are published.

    That's not what I had previously observed, and I will experiment. I really thought I could get more than one going at once, and the bars would move simultaneously and independently. Emphasis on "thought".

    Is this sequential nature new behavior also?

    PS. Parallel is good, especially for those with decent bandwidth. Sounds promising.

  • leftquarkleftquark SmugMug Product Team Posts: 3,277Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

    That behavior isn't new ... and it's possible I'm wrong about that. I'll double-check with David. The new part is being able to upload 3 photos at a time, for a given action :)

    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • FergusonFerguson Major grins Posts: 1,219Registered Users Major grins

    @leftquark said:
    That behavior isn't new ... and it's possible I'm wrong about that. I'll double-check with David. The new part is being able to upload 3 photos at a time, for a given action :)

    Now I'm sure. I just tried the prior version (LR 7.2 on Plugin 3.1.4.0 on windows 10) and created three empty galleries, copied different images into each of the three, and started a publish on each.

    The bars all move, and if I go into them they show photos already published, and indeed on the web site they are there. Attached is a screen shot showing the partial bars, but more importanly the last collection to be published (Test3) is highlighted, and you can see 5 images already published, while the other three are still just getting started.

    I'll give it a go with the new one next.

  • leftquarkleftquark SmugMug Product Team Posts: 3,277Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

    @DuaneA: That's odd, and a bummer to hear! Would you enable debugging log files so we can get a better understanding of what's going on.

    In the Plugin Manager, find the section for "Debuggging" and choose "Enabling Logging". Set it Log Output = Logfile and Log Level = Verbose.

    Then, enable simultaneous uploads, and try to upload more than 12 photos. Once you're done with that, you should see a text file in your Documents folder on your computer called SmugMug LrPublish.log. If you can email that to [email protected], and let them know we asked for the logs, that'd help us get to the root of it.

    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • FergusonFerguson Major grins Posts: 1,219Registered Users Major grins

    @leftquark yeah, it's broken in some fashion.

    I just tried the new version with the same three folders. It started like gangbusters -- three going at once, I looked and my CPU utilization was pegged at 99%.

    But there are two problems. One is that while it appears to be running, LR is not responding properly. I've got three bars moving (or did -- I think they are stopped), and then the CPU stoppped and fell to 22% or so after just a few minutes. The LR screen, when I select any of the published collections will not show them in a grid -- the grid area is just blank. I can select them, and I can even SHOW ON SMUGMUG, but the grid area remains blank.

    And ... yeah, pretty sure they are stuck now.

    If I look on Smugmug, I previously had about 10, 8 and 7 (that's a rough memory but close). Now I have 26, 26, and 21 images in the three galleries, and no more going up. Just stopped.

    I attempted to stop the publish by clicking on the X for all three bars. It took the X but did not stop. CPU is now about 12% solid, but I do not think anything is really being done. Image counts on Smugmug are not going up. It is just hung.

    You might want to reconsider the update.

  • DuaneADuaneA Beginner grinner Posts: 9Registered Users Big grins

    @leftquark: Sure, I will capture a log for you! I will get to it later tonight EST. All symptoms described by @Ferguson match my observations.

  • FergusonFerguson Major grins Posts: 1,219Registered Users Major grins

    I sent a logfile off to help, referencing this thread. Note that enabling logging did not do it. I enabled, did the publish - empty log. I had to restart Lightroom before it would log. (Un)Fortunately the hang is very reproducible, fails after a few dozen images each time, but man does it cank them out for a few minutes, three x three in parallel is my guess. I did it twice, the second time waiting quite a while to be sure it had stopped.

    The end of each log file looks normal to me, it just stopped.

    Both of those were in three threads at once, but I did another run with just one thread and it stopped in the same way.

    Doesn't work at all, basically, for me.

  • FergusonFerguson Major grins Posts: 1,219Registered Users Major grins

    And last update: I tried it with parallel turned off.

    I did it twice, one gallery at a time, and three at a time, and both worked fine.

    So it's the (default) parallel on that cause the failure apparently.

  • leftquarkleftquark SmugMug Product Team Posts: 3,277Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

    Are both of you using Windows (I know @Ferguson is, based on the screenshot). On my Mac, I just successfully publishing 3 galleries (40 photos, 48 photos, and 34 photos), with simultaneous uploads on, all 3 going at the same time. Initially CPU spiked to ~100%, then calmed down and uploads continued. 2 of the 3 galleries have finished and the 3rd is getting close to wrapping up (but I have to step away from the computer).

    We'll continue to investigate.

    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • leftquarkleftquark SmugMug Product Team Posts: 3,277Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

    (got your log files. Thanks @Ferguson )

    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • cedericcederic Big grins Posts: 37Registered Users Big grins

    I can confirm an identical experience to Ferguson. Very unhappy Lightroom 6.10 (and after updating, 6.14) with the default 'do three at once', normal service resumed when I disable that option, restart Lightroom and then start uploading.

    Note that normal service does indeed include asking Lightroom to update 8 different SmugMug galleries, and seeing multiple progress bars progressing at once.

  • FergusonFerguson Major grins Posts: 1,219Registered Users Major grins

    Yeah... the multiple galleries is handy, please don't take that away!

    Though one thing I've found is you can update a folder above many galleries and it sequentially checks all within, which is handy if you are cleaning up and not sure which need to be done. Those then are sequential not simultaneous (which is fine and expected).

  • cedericcederic Big grins Posts: 37Registered Users Big grins

    I did wonder if our naive 'queue up multiple galleries, watch them all progress' is why we hadn't worried before now about concurrent uploads within a single gallery. With 8 going my PC kept fluctuating between 90% and 3% CPU use, as each different thread did processing then uploading, so it spread the load (inefficiently but) adequately.

  • FergusonFerguson Major grins Posts: 1,219Registered Users Major grins

    Yes indeed, @cederic, I have used that often. Though in my case I have a goodly fast connection (25mbs up) and also tend to work on processing as I upload, so I'll process 20 or so, start a publish, move on to the next, about when they are done maybe I'm ready with a few more.

    The new multi-at-once in the same gallery may actually hurt that if it slows down Lightroom so badly I can't work on it.

    But... it has an off switch, so that's just fine. When I do have a bunch to upload and am not processing, it's nice to do 3-at-once. Well, if it worked. I'm sure David will get it fixed soon.

  • richWrichW SmugMug QA Southern CaliforniaPosts: 938Registered Users Major grins

    @cederic @Ferguson @DuaneA for now we rolled back a version to give the developer some time to work out the issue.
    https://files.smugmug.com/lightroom-plugin/SmugMug-3.1.4.0.zip

    Either leftquark or I will post back when the problem has been ironed out.

  • DuaneADuaneA Beginner grinner Posts: 9Registered Users Big grins

    @leftquark said:
    Are both of you using Windows (I know @Ferguson is, based on the screenshot). On my Mac, I just successfully publishing 3 galleries (40 photos, 48 photos, and 34 photos), with simultaneous uploads on, all 3 going at the same time. Initially CPU spiked to ~100%, then calmed down and uploads continued. 2 of the 3 galleries have finished and the 3rd is getting close to wrapping up (but I have to step away from the computer).

    We'll continue to investigate.

    @leftquark: Yes, Windows 64-bit pro. I just sent the logfile.

  • lancerogerslancerogers Beginner grinner Posts: 4Registered Users Beginner grinner
    edited March 2, 2018
    So, I just ran into the same issue, Windows 64-bit Home. Glad this thread is here. Perhaps you all could consider flipping this switch to default to not active until you get it fixed. Really racked my brain before I came here to look. Turning off the switch, my uploads can now proceed.
  • leftquarkleftquark SmugMug Product Team Posts: 3,277Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

    Hi lance. We went one step further and pulled the version from being installed to customers. We can’t change anything once you’ve installed it, but we’ll get to the bottom of it and then put it up for everyone to upgrade to!

    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • DcmackDcmack Big grins Posts: 12Registered Users Big grins

    I just ran into this as well. Took several attempts before did some searches and found this. Any idea when you'll be submitting an update for this?

    Dave Kennedy
  • leftquarkleftquark SmugMug Product Team Posts: 3,277Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

    We're preparing an update either today or tomorrow that will enable simultaneous uploads for Mac users only. For windows users who had upgraded to 3.1.5, this will also disable the feature so you don't run into it (for windows users who hadn't upgraded, this feature will not be available). We're working on a fix so that it works on Windows as well, since it's a feature we're pretty excited to get in all of your hands.

    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • leftquarkleftquark SmugMug Product Team Posts: 3,277Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

    SmugMug Lightroom Plugin v3.1.6.0 should now be live.

    Version 3.1.6.0

    • disable multi-threaded uploading for Windows temporarily
    • improve error handling for multi-threaded uploading
    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • loudandslowloudandslow TravellingPosts: 1Registered Users Beginner grinner
    edited March 13, 2018
    On a Mac, I updated about an hour ago and I've had my computer (not just Lightroom) crash twice after setting the publish running.

    Edit. Just happened without publishing. Not sure what is the culprit, but smugmug is the only thing that has changed..
  • leftquarkleftquark SmugMug Product Team Posts: 3,277Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

    @loudandslow said:
    On a Mac, I updated about an hour ago and I've had my computer (not just Lightroom) crash twice after setting the publish running.



    Edit. Just happened without publishing. Not sure what is the culprit, but smugmug is the only thing that has changed..

    Both of those indications make it appear as if it is not the SmugMug plugin as the cause of the culprit. First, if it was the plugin, it would only impact Lightroom, and not the entire computer. Secondly, the plugin is only invoked when you publish, so if it's happening without publishing, then there may be something else the root of the problem. Super frustrating to hear that the computer is crashing but with all the auto-updates in apps these days, it can be hard to understand what's changed (or in many cases, as an Electrical Engineer by trade, I also know that hardware can deteriorate and start causing computer instabilities).

    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • lancerogerslancerogers Beginner grinner Posts: 4Registered Users Beginner grinner
    So, now that you have held out the carrot so to speak, any word on how the Windows version is coming along? Salivating for faster uploads here....
  • leftquarkleftquark SmugMug Product Team Posts: 3,277Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

    @lancerogers said:
    So, now that you have held out the carrot so to speak, any word on how the Windows version is coming along? Salivating for faster uploads here....

    We’re trying to work with Adobe to understand why there are issues with Windows. We were also super excited to launch this and are eager to get it back into the Windows version as well.

    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • RVetterRVetter FloridaPosts: 5Registered Users Big grins
    edited April 26, 2018
    I've noticed with this update larger videos are failing to publish. I don't hit too often but sometimes you get those time lapse videos that go for a while. I can upload them just fine from the website. I've tried setting the quality from Max H.264 to High and also just passing through as is. The logging just keeps showing.

    04/26/2018 11:35:07 DEBUG SmMedia.upload - start
    04/26/2018 11:35:07 DEBUG Filesize: 2.23 GB
    04/26/2018 11:35:08 DEBUG HTTP Status: 200
    04/26/2018 11:35:08 DEBUG {"stat":"fail","method":"smugmug.images.upload","code":64,"message":"unknown file type"}
    04/26/2018 11:35:08 DEBUG Upload Time: 1s (Timeout: 300s)
    04/26/2018 11:35:08 DEBUG Upload Bandwidth: 51.81 gbps
    04/26/2018 11:35:08 DEBUG {"code":64,"message":"unknown file type","method":"smugmug.images.upload","stat":"fail"}
    04/26/2018 11:35:08 DEBUG SmMedia.upload - end

    The other thing has been that I have to keep selecting a folder and then the gallery in Lightroom to get publisher to pick up changed images. Sometimes several times or even several exits and starts. Seems to become more of a problem as a gallery gets larger.>


    Also videos Date Taken isn't being set right when it goes through Lightroom. It's setting it to create date or modify date.
  • rjwilnerrjwilner USAPosts: 20Registered Users Big grins
    I began to install the update using the Adobe Creative Cloud option, and have noticed that the version listed for the install there is noted as 3.13...which it also lists as applicable for LR versions 4.0-7.0.
    Is it possible they actually have v3.16 and just haven't updated their 'paperwork'?


    I have no problem going the manual install route. Just chose the above as it sounded like the plug-in would be automagically updated along with other CC app updates. That's an attractive feature to me. But if manual install is the only means of getting v3.16 currently.....and is appropriate for LR v7.5, I will go that route.


    Thoughts/ideas/suggestions?

    Thanks!
  • FergusonFerguson Major grins Posts: 1,219Registered Users Major grins

    I can't speak to precisely which version is where, but I know historically there tend to be delays at Adobe, and I always just avoid it and do it from within lightroom as an upgrade. Frankly I can't understand why Smugmug pushes so hard for people to go the Adobe route; I trust getting it direct vastly more than I trust the bureaucracy that is Adobe to get something right and timely.

  • rjwilnerrjwilner USAPosts: 20Registered Users Big grins
    > @Ferguson said:
    > I can't speak to precisely which version is where, but I know historically there tend to be delays at Adobe, and I always just avoid it and do it from within lightroom as an upgrade. Frankly I can't understand why Smugmug pushes so hard for people to go the Adobe route; I trust getting it direct vastly more than I trust the bureaucracy that is Adobe to get something right and timely.

    I started to do it manually, but then decided to give the CC route a try since it appeared to be 'easier', but what you say makes sense. Thanks!
Sign In or Register to comment.