Missing share button?

WoodButch4WoodButch4 Beginner grinnerPosts: 23Registered Users Big grins

It was there last night on my home computer. On my laptop today and it is gone. Logged out and back in, still not there. Checked a couple of galleries and also the settings for them. Still set.

woodbutcher.smugmug.com Here's a specific gallery where I saw the problem. https://woodbutcher.smugmug.com/Animals/Screech-Owl

Comments

  • leftquarkleftquark SmugMug Product Team Posts: 3,442Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

    There's no gallery wide share button (though it's something I'd love to add). The Share Button has always lived on individual images. In SmugMug style galleries it lives underneath the big, selected photo. In Collage Landscape galleries, like this one, the Share Button exists when you open a photo in the Lightbox. It does look like it's there.

    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • WoodButch4WoodButch4 Beginner grinner Posts: 23Registered Users Big grins

    Yes, I've been doing this for years and realize it is only by image, However, your bug report asks for which gallery. I'm home now and have checked on other computers. It is only on my MacbookPro with High Sierra and retina display that doesn't show the share button. It is running the same version of Chrome as the other two macs that work correctly.

    Here is a screenshot to show the lack of the share button on an image in the gallery I listed.

  • Lille UlvenLille Ulven Lille Ulven ScandinaviaPosts: 508Registered Users Major grins

    @WoodButch4 I just tested your gallery with Chrome Version 65.0.3325.181 (Offizieller Build) (64-Bit) on my MacBook Pro Mid2015 Retina: the share button is perfectly visible. Updated to Chrome Version 66.0.3359.139 (Offizieller Build) (64-Bit) and it still is visible.
    If it still does not work on that computer for you could you test with another browser (version)?

    http://www.lilleulven.com - The Photos of my travels
    http://blog.lilleulven.com - The Stories of my travels
  • RichardRichard Mildly bemused Madrid, SpainPosts: 18,834Administrators, Vanilla Admin moderator

    I'm not seeing the share button in Firefox (Win7) but I do see it in Chrome (Win7). I think it has been missing in FF for some time now.

  • WoodButch4WoodButch4 Beginner grinner Posts: 23Registered Users Big grins

    Okay, tested in current Safari and it shows there. Double checked Chrome and still not showing. I have notice on some sites (not smugmug) that the favicon won't show on a retina display, but if I slide the window over to my 1080p display it shows. So I tried that also with the share button, but no dice. I also hovered in that location to see if it existed, but wasn't displaying. Next I'll fire up the developer view and see if Chrome is throwing errors.

  • WoodButch4WoodButch4 Beginner grinner Posts: 23Registered Users Big grins

    And looking at the dev console got me a clue. Major upgrade a week or so ago on my ad-blocker. I run the same one on both computers, but don't block anything on my home computer. On the laptop I do run in on most sites and there was a new setting for blocking social media tracking. The share button was getting blocked by that. So I had two options and I took one.

    So, problem solved, all on my end. Hope this update helps somebody else out.

  • ziggy53ziggy53 Still learnin'still lovin Posts: 20,934Super Moderators moderator

    I can confirm that Ad Block Plus (ABP) is causing my Windows 7 Chrome browser to stop showing the Share icon. Turning off ABP for the site allows the Share icon to display.

    I will notify the author of ABP of the problem.

    ziggy53
    Moderator of the Cameras and Accessories forums
  • RichardRichard Mildly bemused Madrid, SpainPosts: 18,834Administrators, Vanilla Admin moderator
    edited April 27, 2018

    ^ Well, that's weird. For me, it's the reverse. ABP was blocking in in FF but is not blocking in Chrome. I'm also on Win7. ABP does say it's blocking one link in Chrome, but it's not the Share button. I rely mostly on the default blacklists, which are updated automatically. Maybe they're different in Europe than in the US? Dunno.

  • WoodButch4WoodButch4 Beginner grinner Posts: 23Registered Users Big grins

    @ziggy53 said:
    I can confirm that Ad Block Plus (ABP) is causing my Windows 7 Chrome browser to stop showing the Share icon. Turning off ABP for the site allows the Share icon to display.

    I will notify the author of ABP of the problem.

    I suspect it is just a matter of the new social media blocking option, but I would have thought it would block the Facebook, Twitter, IG type icons. The sharing button here has more functionality than just social sharing. I just turned off blocking on my smugmug page. I kind of like the social icon blocking. Well, other than the issue I ran into here...

  • David_S85David_S85 Spotter of Dgrin Spam and Oddities ChicagolandPosts: 12,284Administrators moderator

    So I tried the OP's site and pics yesterday in Chrome (Mac) and there was no share button. Just tried it again, and the Share is now visible. Must have been the ABP.

    My Smugmug
    "You miss 100% of the shots you don't take" - Wayne Gretzky
  • ziggy53ziggy53 Still learnin'still lovin Posts: 20,934Super Moderators moderator

    I received a response from the creators of ABP and they requested more information, which I supplied to them.

    In the meantime, Both ABP and Chrome have pushed updates onto my machine and the problem seems to be resolved, but I am still requesting that they default ABP to whitelist the entire SmugMug domain.

    ziggy53
    Moderator of the Cameras and Accessories forums
  • WoodButch4WoodButch4 Beginner grinner Posts: 23Registered Users Big grins

    Thanks for all the digging into all of this. I'll make sure ABP updates and try again, but I was happy once we figured out where the issue was.

  • ziggy53ziggy53 Still learnin'still lovin Posts: 20,934Super Moderators moderator
    edited May 2, 2018

    I received the following e-mail back from the ABP representative:

    "Hi ziggy53,

    Thanks for your detailed response!

    I can actually reproduce this issue ...

    This is a false positive in the Sociel Media blocking list that need to be fixed by the filter list maintainers. I will forward this it them so they can take action.

    Best regards,
    (His name)"

    ziggy53
    Moderator of the Cameras and Accessories forums
  • ziggy53ziggy53 Still learnin'still lovin Posts: 20,934Super Moderators moderator

    Another e-mail from ABP:

    "Hi ziggy53,

    This issue should be fixed now. This update should reach all users of that filter list within a few days. As a user you can also manually enforce an update in Adblock Plus' options.

    Best regards,
    His name"

    ziggy53
    Moderator of the Cameras and Accessories forums
  • ziggy53ziggy53 Still learnin'still lovin Posts: 20,934Super Moderators moderator

    To update ABP:

    • Make sure that you have access to the Internet.
    • Mouse-click on the ABP icon to open the Adblock Plus toolbox and controls.
    • Click on the "Options" tab.
    • Click on the "Advanced" tab.
    • Scroll down to "Filter Lists".
    • Click the "Update All Filter Lists".

    If you had SmugMug open, be sure to refresh your browser. The Share option should now be available as normal.

    ziggy53
    Moderator of the Cameras and Accessories forums
Sign In or Register to comment.