Why I still can see filenames?

david-lowdavid-low Amateur hobbyistSingaporePosts: 709Registered Users Major grins

I turned OFF "Show Filenames" and from my understanding, file names will not be displayed with or without caption. I intentionally log in as guest but I still can see filenames, with or without caption. Why is that so?

Comments

  • rainforest1155rainforest1155 SmugMug Support Hero Posts: 4,478Registered Users Major grins

    Hi David,
    If you can post a link to an example photo, we could take a closer look.

    A possibility is that in your photo processing workflow, you enabled some setting in your photo managing / editing software to embed the filename as the caption of the photo. In that case, this caption would be automatically imported as the SmugMug caption and would not be considered a filename at all anymore, thus the filename setting would not have effect on it.
    You can easily identify such cases by clicking on the pencil icon next to the filename in question and if the filename is still shown within the edit caption field, it's part of the caption and likely was added to it by your photo software prior to uploading the photo to SmugMug.

    All the best,

    Sebastian
    SmugMug Support Hero
  • david-lowdavid-low Amateur hobbyist SingaporePosts: 709Registered Users Major grins
    edited October 10, 2018

    @rainforest1155 said:
    Hi David,
    If you can post a link to an example photo, we could take a closer look.

    A possibility is that in your photo processing workflow, you enabled some setting in your photo managing / editing software to embed the filename as the caption of the photo. In that case, this caption would be automatically imported as the SmugMug caption and would not be considered a filename at all anymore, thus the filename setting would not have effect on it.
    You can easily identify such cases by clicking on the pencil icon next to the filename in question and if the filename is still shown within the edit caption field, it's part of the caption and likely was added to it by your photo software prior to uploading the photo to SmugMug.

    All the best,

    Tks Rainforest,
    I didn't received any notification abt your reply (prob during the midst of changing my email), hence I hv forgotten abt my posting. Besides I was under the rock for quite sometime. So sorry and tks for your reply.

    Most of my photo were edited thru Photoshop, saved with the default camera file name. No other further editing was imposed on it. Then I simply upload the photo, add in my caption, if any.

    In Gallery Setting, I set "Show Filenames to OFF".

    I click the pencil icon besides the filename and the filename still show. But I didn't do anything to the photo besides doing some exposure and level stuff in Photoshop. Not that I know I have embeded the filename by any accident. I don't really think so I did that.

    I en a typical pic that shows caption, with a filename below it.

    If you were to click any photo in my website, you will see the same behaviour.

    Appreciate your further advise.

  • pilotdavepilotdave Major grins Posts: 754Registered Users Major grins

    You seem to have filename keywording turned on. This will create keywords from your filenames. It wins the award for smugmug's #1 worst feature! You can shut that off in your settings (everybody should), but that won't delete the useless keywords it's already created.

    Dave

  • Hero JackieHero Jackie Beginner grinner Posts: 10Registered Users Big grins

    David, as Dave mentioned, you have filename keywording turned on, here: https://secure.smugmug.com/settings/?nick=david-low#section=search

    But, you can remove the keywords. You can go to Organize, select all photos in a gallery then click on the Wrench>Title, Caption, Keywords, here: https://screencast.com/t/78k1CxXR

    Then, you can remove them here: https://screencast.com/t/RPmQpmXI Or in that same page, only highlight one photo and you can remove just the keyword from one if you don't wish to remove them all.

  • david-lowdavid-low Amateur hobbyist SingaporePosts: 709Registered Users Major grins

    Hi Dave and Jackie,

    Tks so much for helping and so sorry for my ignorance. I have further questions:

    @Hero Jackie said:
    David, as Dave mentioned, you have filename keywording turned on, here: https://secure.smugmug.com/settings/?nick=david-low#section=search

    But, you can remove the keywords. You can go to Organize, select all photos in a gallery then click on the Wrench>Title, Caption, Keywords, here: https://screencast.com/t/78k1CxXR

    Then, you can remove them here: https://screencast.com/t/RPmQpmXI Or in that same page, only highlight one photo and you can remove just the keyword from one if you don't wish to remove them all.

    Wow, I didn't know the turning off the filename is embedded a few levels inside the menu. I experimented and it works. Questions:

    1) It seems I have to do the same steps to every galleries. Is that correct? How do I apply globally?

    2) After "REMOVE ALL", how to reinstate back the filename assuming next time I prefer to have the filename to be shown. I don't seems able to reinstate back

  • david-lowdavid-low Amateur hobbyist SingaporePosts: 709Registered Users Major grins

    Hello?

  • pilotdavepilotdave Major grins Posts: 754Registered Users Major grins

    You may be able to remove the keywords from all your galleries at once with some creative use of a temporary smart gallery that puts everything in one place. If you don't use any other keywords, I think you can clear them all at once.

    I'm not sure I understand your second question. You can turn filename keywording back on later, but please don't. It only makes a mess. The alternative is to turn on display filenames, which will show filenames when captions are left blank.

    Personally, I use Lightroom and a plugin called LR Transporter to add filenames to my captions.

    Dave

Sign In or Register to comment.