Share and Info not working in Chrome (Mac)

David_S85David_S85 Spotter of Dgrin Spam and OdditiesChicagolandPosts: 12,398Administrators moderator
edited January 15, 2019 in Bug Reporting

Any attempt to use Share in normal Lightbox or in Organizer Lightbox does nothing. Same with the Info tool - just spins forever and displays nothing. Maps also seem to be down.

Also Show/Hide toggle in Organizer is not working. In fact, now all the tools are grayed out and unavailable. All galleries on my entire site are almost non-functionable from any management. Looks like read-only, and only barely.

My Smugmug
"You miss 100% of the shots you don't take" - Wayne Gretzky

Comments

  • Hikin' MikeHikin' Mike Walkin' like a Penguin! Atwater, CaPosts: 4,478Registered Users Major grins
  • David_S85David_S85 Spotter of Dgrin Spam and Oddities ChicagolandPosts: 12,398Administrators moderator

    Logged off SM. Cleared all cookies, etc. Closed down Chrome. Reopened and signed back onto SM. Still nothing. My internet checks out. Gotta be something with SM.

    My Smugmug
    "You miss 100% of the shots you don't take" - Wayne Gretzky
  • leftquarkleftquark SmugMug Product Team Posts: 3,623Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

    Checked on 2 different computers (both Mac, Chrome and Safari) and I can use the Share/Info Panels without issues. Do you notice any issues in the console (right click and choose "Inspect" in Chrome, if that's what you're using)?

    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • David_S85David_S85 Spotter of Dgrin Spam and Oddities ChicagolandPosts: 12,398Administrators moderator
    edited January 15, 2019

    I am running Inspect, but I don't know what I should be looking for. I'd share a screen shot, but I can't since share isn't working.

    Maybe this? I clicked Info and get the 4 dot loading animation (which never loads with anything).

    XMLHttpRequest cannot load https://api.smugmug.com/api/v2/album/XrG2Lg/image/WpP2Chq?_shorturis&APIKey…shorturis%3D,ImageSizeDetails%3F_shorturis%3D,LargestImage%3F_shorturis%3D. The request was redirected to 'https://api.smugmug.com/api/v2/album/XrG2Lg/image/WpP2Chq-0?_shorturis=&API…shorturis%3D,ImageSizeDetails%3F_shorturis%3D,LargestImage%3F_shorturis%3D', which is disallowed for cross-origin requests that require preflight. organizer-113cefb….js:746 [sm-resource-core] Object {method: "_request", uri: "/api/v2/album/XrG2Lg/image/WpP2Chq", error: Error: 0 at Object.s._handleResponse (https://cdn.smugmug.com/include/js/bundles/organizer-113c…}n.console @ organizer-113cefb….js:746(anonymous function) @ organizer-113cefb….js:729(anonymous function) @ organizer-113cefb….js:860(anonymous function) @ organizer-113cefb….js:860(anonymous function) @ organizer-113cefb….js:871v @ organizer-113cefb….js:871n.exports @ core-top-c5aadc1….js:16y.(anonymous function) @ core-top-c5aadc1….js:16b @ core-top-c5aadc1….js:16x @ core-top-c5aadc1….js:16 /organize/Vacation/Vermont-2018-Outtakes/i-WpP2Chq:1 XMLHttpRequest cannot load https://api.smugmug.com/api/v2/image/WpP2Chq?_shorturis&APIKey=W0g9oqdOrzuh…ose&_expand=ImageMetadata%3F_shorturis%3D,ImageSizeDetails%3F_shorturis%3D. The request was redirected to 'https://api.smugmug.com/api/v2/image/WpP2Chq-0?_shorturis=&APIKey=W0g9oqdOr…se=&_expand=ImageMetadata%3F_shorturis%3D,ImageSizeDetails%3F_shorturis%3D', which is disallowed for cross-origin requests that require preflight. organizer-113cefb….js:746 [sm-resource-core] Object {method: "_request", uri: "/api/v2/image/WpP2Chq", error: Error: 0 at Object.s._handleResponse (https://cdn.smugmug.com/include/js/bundles/organizer-113c…}n.console @ organizer-113cefb….js:746(anonymous function) @ organizer-113cefb….js:729(anonymous function) @ organizer-113cefb….js:860(anonymous function) @ organizer-113cefb….js:860(anonymous function) @ organizer-113cefb….js:871v @ organizer-113cefb….js:871n.exports @ core-top-c5aadc1….js:16y.(anonymous function) @ core-top-c5aadc1….js:16b @ core-top-c5aadc1….js:16x @ core-top-c5aadc1….js:16 /organize/Vacation/Vermont-2018-Outtakes/i-WpP2Chq:1 XMLHttpRequest cannot load https://api.smugmug.com/api/v2/image/WpP2Chq?_shorturis&APIKey=W0g9oqdOrzuh…ose&_expand=ImageMetadata%3F_shorturis%3D,ImageSizeDetails%3F_shorturis%3D. The request was redirected to 'https://api.smugmug.com/api/v2/image/WpP2Chq-0?_shorturis=&APIKey=W0g9oqdOr…se=&_expand=ImageMetadata%3F_shorturis%3D,ImageSizeDetails%3F_shorturis%3D', which is disallowed for cross-origin requests that require preflight. organizer-113cefb….js:746 [sm-resource-core] Object {method: "_request", uri: "/api/v2/image/WpP2Chq", error: Error: 0 at Object.s._handleResponse (https://cdn.smugmug.com/include/js/bundles/organizer-113c…}n.console @ organizer-113cefb….js:746(anonymous function) @ organizer-113cefb….js:729(anonymous function) @ organizer-113cefb….js:860(anonymous function) @ organizer-113cefb….js:860(anonymous function) @ organizer-113cefb….js:871v @ organizer-113cefb….js:871n.exports @ core-top-c5aadc1….js:16y.(anonymous function) @ core-top-c5aadc1….js:16b @ core-top-c5aadc1….js:16x @ core-top-c5aadc1….js:16

    I can't get this to work at other Smugmug sites either. This all began tonight. Was working yesterday just fine. I haven't changed any setting in Chrome.

    My Smugmug
    "You miss 100% of the shots you don't take" - Wayne Gretzky
  • David_S85David_S85 Spotter of Dgrin Spam and Oddities ChicagolandPosts: 12,398Administrators moderator
    edited January 15, 2019

    Aaron, I put up a screenshot on my SM (link in sig), which I can not share here :( , onto my site under...

    Portfolio > Main Galleries > Forum Pics and Videos

    Then it is the first shot up at the top left. Click that. Hope there is a clue there. I'm going down for sleep. Back in 8-10 hours.

    My Smugmug
    "You miss 100% of the shots you don't take" - Wayne Gretzky
  • angleasindyreidangleasindyreid swindon ukPosts: 1Registered Users Beginner grinner
    > @David_S85 said:
    > Any attempt to use Share in normal Lightbox or in Organizer Lightbox does nothing. Same with the Info tool - just spins forever and displays nothing. Maps also seem to be down.
    >
    > Also Show/Hide toggle in Organizer is not working. In fact, now all the tools are grayed out and unavailable. All galleries on my entire site are almost non-functionable from any management. Looks like read-only, and only barely.

    My share button is visable but as of today 15th Jan 2019 it won't do anything. Strange as it worked just yesterday.
  • David_S85David_S85 Spotter of Dgrin Spam and Oddities ChicagolandPosts: 12,398Administrators moderator
    edited January 15, 2019

    @angleasindyreid said:
    My share button is visible but as of today 15th Jan 2019 it won't do anything. Strange as it worked just yesterday.

    Yup. same here. Worked yesterday and not today. All the tools buttons in the bottom of the Lightbox views (Organizer or regular) are there, but only a couple do anything. Info is blank and maps tab not even visible. Share visible but does nothing when clicked. I can't post photos to any forum or other with this not operating.

    Glad it isn't just me and my old Mac.

    Something clearly on Smugmug's end.

    My Smugmug
    "You miss 100% of the shots you don't take" - Wayne Gretzky
  • denisegoldbergdenisegoldberg Major grins North Andover, MAPosts: 12,432Super Moderators moderator

    I'm seeing the same problem in the Edge browser but Firefox and Chrome continue to work properly.

  • David_S85David_S85 Spotter of Dgrin Spam and Oddities ChicagolandPosts: 12,398Administrators moderator

    ...and I was about to DL the Edge. :/ Guess not. Thanks for reporting this same problem, Denise.

    My Smugmug
    "You miss 100% of the shots you don't take" - Wayne Gretzky
  • David_S85David_S85 Spotter of Dgrin Spam and Oddities ChicagolandPosts: 12,398Administrators moderator

    Aaron, any update on this issue?

    My Smugmug
    "You miss 100% of the shots you don't take" - Wayne Gretzky
  • leftquarkleftquark SmugMug Product Team Posts: 3,623Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

    @David_S85 said:
    Aaron, any update on this issue?

    It should have been fixed this afternoon. Are you still seeing issues?

    SmugMug Director of Product / dGrin Afficionado
    aaron AT aaronmphotography DOT com
    Website: http://www.aaronmphotography.com
    My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
  • David_S85David_S85 Spotter of Dgrin Spam and Oddities ChicagolandPosts: 12,398Administrators moderator
    edited January 17, 2019

    Thanks, Aaron. Don't know what you guys did, but it now seems resolved. Thank You!

    Info: Dialog box now shows EXIF. The Map tab shows and displays.

    Share: seems to display all functions.

    Hide/Unhide: Works.

    My Smugmug
    "You miss 100% of the shots you don't take" - Wayne Gretzky
Sign In or Register to comment.