"Organize" function no longer working

My3SonsMy3Sons Major grinsPosts: 132Registered Users Major grins

When I'm in a gallery, if I click on "Organize", I can't get the page to pull up correctly. This started yesterday morning and is still continuing today. I need to organize images in my portfolio, but I also need to reopen another gallery and change it's password. I cannot do either of those things, without the pages working. When I click on Organize, it goes to a black page, where I can see all of my galleries on the left side of the page, but that is all that I can see. It should allow me to access all gallery settings, but they are missing.

Just in case it is a browser issue- I've tried updating my browser in case that is the issue, but that is not an option for me. I'm using Safari and I'm on Mavericks (OS 10.9.5) and cannot update my OS since my Mac cannot support a newer OS. I cannot find an update for my current OS.

Can you check to see if there is a bug, or something strange going on with my website?
This is my site: www.bellagracephotograpynow.com

I'll attach a screenshot of what I see when I'm in a gallery and I click on Organize.

thank you, Melissa

Comments

  • JenuineJenuine Big grins Posts: 88Registered Users SmugMug Employee

    With recent changes to the site the 10.10 operating system isn't working well. It has more favor with Chrome or Firefox on the latest browser versions for each of those. Our help page will be updated soon to advise that the supported system will be 10.11 and up. We know this is not what one wants to hear when not able to upgrade the operating system further, but sadly this is what happens with technology and time.

    Jen
    SmugMug Support Hero
  • My3SonsMy3Sons Major grins Posts: 132Registered Users Major grins

    I downloaded Chrome and it works perfectly with Chrome. I was wondering if it was something like that. Thanks for getting back to me!

Sign In or Register to comment.