Need SM Support Help Undoing CSS Customization

rjwilnerrjwilner USARegistered Users Posts: 85 Big grins

it appears I will need assistance undoing some CSS I had deployed as a Lightbox customization. Totally 'my bad', but it appears I've managed a doozy this time.

The goal was to replace the 'Info' icon with text. I found the CSS needed to add a text option in the Info bar and implemented that w/o issue.

But doing the above just added the text option in the Info bar. Now I needed to find the appropriate CSS to remove the 'i' icon. And that's where the trouble began.

I thought I had determined the appropriate CSS needed. So, I opened a gallery, went to Customize (for All Galleries), selected CSS and entered what I thought was the appropriate CSS. Saved it and Published.

Not only did it remove the 'i' icon, it removed _**every last bit **_of 'Info' typicall ydisplayed in the Lightbox. 'Yikes! Guess that wasn't the appropriate css. No biggie. I'll just go back and remove that bit of css. ', I thought.

Except I can't! Now, when I load a gallery, select Customize (again, All Gallleries), and start scrolling down through the list of 'Content' items, they are all visible, but none of them are actionable. I.e., I can click any one of them, but nothing happens. So, now I have no means of undoing the errant CSS I'd entered.

Any help/suggestions would be greatly appreciated. Like as not, someone will need add'l info to help. Just let me know what is needed. If it makes any diff, I was in the following gallery while doing all this...
https://www.rjwilner.photography/Color/Wildlife/

Comments

  • AllenAllen "tweak 'til it squeaks" St. Louis, MoRegistered Users Posts: 9,930 Major grins

    Like this?

    Al - Just a volunteer here having fun
    My Website index | My Blog
  • AllenAllen "tweak 'til it squeaks" St. Louis, MoRegistered Users Posts: 9,930 Major grins
    .sm-user-ui .sm-lightbox-v2 .sm-lightbox-v2-navbar-primary li:nth-child(2) .sm-button-square:after {
     content:" INFO & CAPTION On/Off";
     font-size:75%;
     background:#222;
     color:#ff0
    }
    
    Al - Just a volunteer here having fun
    My Website index | My Blog
  • rjwilnerrjwilner USARegistered Users Posts: 85 Big grins
    edited May 28, 2021

    @Allen said:

    .sm-user-ui .sm-lightbox-v2 .sm-lightbox-v2-navbar-primary li:nth-child(2) .sm-button-square:after {
     content:" INFO & CAPTION On/Off";
     font-size:75%;
     background:#222;
     color:#ff0
    }
    

    Yes, that's what I was trying to add. And though my text differed, that was successful. (And thanks for posting that in the original Lightbox Customization thread!)

    Where I ran into issues was when I then went back in and added some css to (hopefully) remove the 'i' icon. Whatever I added, it seems to have had a far more reaching impact than I would have thought possible. I can't even open the css dialog now to undo what I added.

  • rjwilnerrjwilner USARegistered Users Posts: 85 Big grins

    The attached screen cap might help illustrate the issue I'm having. The various 'Content' options are all visible, but I'm unable to do anything with them. They aren't 'clickable'.

    I wouldn't have guessed me adding css for a gallery would have caused this problem, but everything had been functioning just honky dorry up until I did.

  • denisegoldbergdenisegoldberg Major grins North Andover, MASuper Moderators Posts: 13,339 moderator

    @rjwilner said:
    The attached screen cap might help illustrate the issue I'm having. The various 'Content' options are all visible, but I'm unable to do anything with them. They aren't 'clickable'.

    You might try contacting the SmugMug help desk to see if they can fix the problem.

    https://help.smugmug.com/email-a-smugmug-support-hero-rkwelDyVrz

  • rjwilnerrjwilner USARegistered Users Posts: 85 Big grins

    @denisegoldberg said:

    @rjwilner said:
    The attached screen cap might help illustrate the issue I'm having. The various 'Content' options are all visible, but I'm unable to do anything with them. They aren't 'clickable'.

    You might try contacting the SmugMug help desk to see if they can fix the problem.

    https://help.smugmug.com/email-a-smugmug-support-hero-rkwelDyVrz

    Thanks! Should have thought of that.

  • AllenAllen "tweak 'til it squeaks" St. Louis, MoRegistered Users Posts: 9,930 Major grins
    edited May 29, 2021

    I could find nowhere that I removed the 'i' icon. So I assumed my CSS replaced it.

    Ah, I see you got the Mandarin Duck at St. Ferdinand Park also.

    Al - Just a volunteer here having fun
    My Website index | My Blog
  • JtringJtring Major grins CaliforniaRegistered Users Posts: 628 Major grins

    I may be too late to the party to help anything, but if the SmugMug Heros haven't baled you out yet, you might be able to fix things yourself ... if you are familiar with the browser web developer tools. In Firefox, they are a selection in the hamburger menu. In Chrome, they in the three-dot menu but inside the "more tools" pop-out. In any case if you open up the Customizer on one of the galleries and then launch the developer tools, you can inspect and change the CSS on the local copy in front of you. In particular, you might be able to find and undo whatever CSS rule is making the content selections unclickable. I'd suspect something like a CSS rule that hides, among other things, the wrench icon that normally shows on the right side of each content item. Once that's undone on the local copy, you can do the permanent edit: bring up the piece of errant CSS as you normally would in the Customizer and change or remove it. Save. Now if you've not used the developer tools, I suspect what I've just written makes no sense at all, in which case the Heros can be your way out.

    I had to do something like what I described above once. It was a while back, so I don't remember the details, but somehow I managed hide every last link to log in as the site owner when logged-out. I hadn't realized I had done so ... until I logged out.

    Jim Ringland . . . . . jtringl.smugmug.com
  • Hikin' MikeHikin' Mike Walkin' like a Penguin! Atwater, CaRegistered Users Posts: 5,251 Major grins

    @Jtring said:
    I may be too late to the party to help anything, but if the SmugMug Heros haven't baled you out yet, you might be able to fix things yourself ... if you are familiar with the browser web developer tools. In Firefox, they are a selection in the hamburger menu. In Chrome, they in the three-dot menu but inside the "more tools" pop-out. In any case if you open up the Customizer on one of the galleries and then launch the developer tools, you can inspect and change the CSS on the local copy in front of you. In particular, you might be able to find and undo whatever CSS rule is making the content selections unclickable. I'd suspect something like a CSS rule that hides, among other things, the wrench icon that normally shows on the right side of each content item. Once that's undone on the local copy, you can do the permanent edit: bring up the piece of errant CSS as you normally would in the Customizer and change or remove it. Save. Now if you've not used the developer tools, I suspect what I've just written makes no sense at all, in which case the Heros can be your way out.

    I had to do something like what I described above once. It was a while back, so I don't remember the details, but somehow I managed hide every last link to log in as the site owner when logged-out. I hadn't realized I had done so ... until I logged out.

    Done that a few times myself...lol!

  • rjwilnerrjwilner USARegistered Users Posts: 85 Big grins

    @Allen said:
    I could find nowhere that I removed the 'i' icon. So I assumed my CSS replaced it.

    Ah, I see you got the Mandarin Duck at St. Ferdinand Park also.

    it did surprise me when the 'i' remained. I'm going to have to take another look at what I might have done differently.

    And...., you're in STL? I knew you were in MO, but somewhere got the notion you were some distance outside STL.

  • rjwilnerrjwilner USARegistered Users Posts: 85 Big grins

    @Jtring said:
    I may be too late to the party to help anything, but if the SmugMug Heros haven't baled you out yet, you might be able to fix things yourself ... if you are familiar with the browser web developer tools. In Firefox, they are a selection in the hamburger menu. In Chrome, they in the three-dot menu but inside the "more tools" pop-out. In any case if you open up the Customizer on one of the galleries and then launch the developer tools, you can inspect and change the CSS on the local copy in front of you. In particular, you might be able to find and undo whatever CSS rule is making the content selections unclickable. I'd suspect something like a CSS rule that hides, among other things, the wrench icon that normally shows on the right side of each content item. Once that's undone on the local copy, you can do the permanent edit: bring up the piece of errant CSS as you normally would in the Customizer and change or remove it. Save. Now if you've not used the developer tools, I suspect what I've just written makes no sense at all, in which case the Heros can be your way out.

    I had to do something like what I described above once. It was a while back, so I don't remember the details, but somehow I managed hide every last link to log in as the site owner when logged-out. I hadn't realized I had done so ... until I logged out.

    I did get some assistance from the Help Desk, but glad you posted this...just in case there's a 'next time'. :)

Sign In or Register to comment.