SmugMug's Lightroom Plugin Failing on LrC 10.3 (Native M1)

JoePhotoVAJoePhotoVA VirginiaRegistered Users Posts: 1 Beginner grinner
I upgraded to LrC 10.3 with native M1 support this morning and then tried to publish some changed photos to SmugMug. The process seemed normal until the preparing to export message completed. At that point, the progress bar filled immediately and a red x appeared next to the task display. The upload seemingly failed on initiation, perhaps because the SmugMug plugin is not compatible with Apple’s M1.

This is a major problem for me as my workflow depends on your plugin working. Can anyone help?

I have verified that I have the newest version of the Plugin, LrC, and MacOS.

I popped into the plugin manager and found a message that says this about the SmugMug plugin: “This plug-in is enabled, but encountered some problems.”

I also dumped the error log from LrC for the Plugin and found the following:

Plug-in error log for plug-in at: /Users/barrettjg/Library/Application Support/Adobe/Lightroom/Modules/SmugMug.lrplugin

**** Error 1

This plug-in’s post-processing task did not finish successfully.
<AgErrorID>canceled</AgErrorID>

**** Error 2

This plug-in’s post-processing task did not finish successfully.
<AgErrorID>canceled</AgErrorID>

**** Error 3

This plug-in’s post-processing task did not finish successfully.
<AgErrorID>canceled</AgErrorID>

**** Error 4

This plug-in’s post-processing task did not finish successfully.
<AgErrorID>canceled</AgErrorID>

Comments

Sign In or Register to comment.