Publishing from Lightroom class to SmugMug error (out of sync)

PaulKlompPaulKlomp Registered Users Posts: 1 Beginner grinner
edited June 15, 2022 in SmugMug Support
When I publish from Lightroom classic to SmugMug using 3.3.0.0 of the app I get an "out of sync" error.
"Lightroom is out of sync with SmugMug"
"The gallery was not created because Lightroom could not locate the parent folder on SmugMug.
Click "Sync Folders and Galleries" now to update and resolve this problem.
Tip: Click "Sync Folders and Galleries" after using the Organizer to rearrange your SmugMug site to import the changes back into Lightroom."

When I click, Sync Folder and Galleries, I get the following message:
"Can't update this collection.: An internal error has occurred: bad argument #1 to 'find' (string expected, got nil)

Any suggestions?

Comments

  • denisegoldbergdenisegoldberg Major grins North Andover, MAAdministrators Posts: 13,811 moderator
    edited June 15, 2022

    Have you tried contacting the SmugMug help desk directly? While they check in here periodically you will likely get a faster response there.

    https://www.smugmughelp.com/en/articles/309-contact-a-smugmug-support-hero#

  • parallaxphotosparallaxphotos Beginner grinner Registered Users Posts: 6 Big grins

    No suggestions, but I am having the same problem.

  • parallaxphotosparallaxphotos Beginner grinner Registered Users Posts: 6 Big grins

    I received the following response. That was so fast!

    Thank you for contacting SmugMug.

    We are aware of the issue with the Lightroom plugin and have reproduced this issue on our end. We have narrowed down the issue to be when a publish gallery is created in a publish folder.

    Use the following work around to create and publish galleries in the SmugMug Publisher:

    Please delete the publish gallery created and restart Lightroom.

    Create the publish gallery on the root of the publisher, not in a publish folder as shown in this screen capture:

    Publish the images.

    Then that publish gallery can be moved to the desired publish folder.

    I apologize for the inconvenience and we hope to have a plugin update very soon.

  • JtringJtring Major grins CaliforniaRegistered Users Posts: 645 Major grins
    edited June 16, 2022

    This one hit me too. I chose a second option. I reverted to an earlier version of the plug-in. I’m on Windows, so I can describe how to do that there. Someone else will have to take on other systems. It’s a bit involved, which is probably why the Help Desk didn't suggest it. Anyway, here goes:

    1. In Lightroom’s Library module, in the Publish Services section of the bar at the left, left-click the line with the SmugMug icon and name. From the menu that comes up, select “Edit Settings”.
    2. Up comes the Lightroom Publishing Manager. Way down at the bottom left is a button labeled “Plug-in Manager”. Click that button.
    3. Up comes the Lightroom Plug-in Manager with the information on the SmugMug plug-in. In the main (right) area, there’s a section labeled “Status”. In that section, there’s a line that begins “Path:” and beneath it a button labeled “Show in Explorer”. Click that button.
    4. You are now in the folder with all the Lightroom plugins. You should see a file named “SmugMug.lrplugin”. That’s the current, live plug-in. You should also see old plugins, with names like “SmugMug-3.2.7.0.lroldplugin”. If you don’t find that particular name, find the most recent file with a name like that but with different numbers. You are now ready to make a switch.
    5. Change the name of “SmugMug.lrplugin” to something else, like “SmugMug-3.3.0.0”.
    6. Change the name of “SmugMug-3.2.7.0.lroldplugin” (or whatever you found at step 4) to “SmugMug.lrplugin”.
    7. Restart Lightroom. Your old plugin version should now be the live one.
    8. If something is messed up, you can reverse steps 5 and 6, restart Lightroom, and be back to where you started.

    Of course, a third option is just to wait until SmugMug fixes this. My guess is that this is important enough that it won’t be long.

    Jim Ringland . . . . . jtringl.smugmug.com
  • JtringJtring Major grins CaliforniaRegistered Users Posts: 645 Major grins

    I see the plug-in has been updated to version 3.3.1.0. It solves this problem.

    Jim Ringland . . . . . jtringl.smugmug.com
Sign In or Register to comment.