Change in SmugMug URLs for better privacy

1235»

Comments

  • brandofamilybrandofamily Just a Guy with a Camera Illinois USARegistered Users Posts: 2,007 Major grins
    edited February 17, 2008
    bigwebguy wrote:
    Ah, thats not Traditional, thats SingleImage...but yeah my fault for not seeing what you were talking about.

    ImageKey is indeed missing on that page. I'll make sure to add it for my next round of updates.

    Sorry about that.
    When might that round take place?
  • AndyAndy Bicameral New YorkRegistered Users Posts: 50,154 Major grins
    edited February 17, 2008
    When might that round take place?
    When it does. Sorry Anthony, we can't & don't give dates. But rest assured, it's on the list to be addressed.
  • brandofamilybrandofamily Just a Guy with a Camera Illinois USARegistered Users Posts: 2,007 Major grins
    edited February 17, 2008
    Andy wrote:
    When it does. Sorry Anthony, we can't & don't give dates. But rest assured, it's on the list to be addressed.
    I'm certain it's on the "to do list." But when my site is broken I can't rest very well... I guess I can only hope it's sooner than later....
  • AndyAndy Bicameral New YorkRegistered Users Posts: 50,154 Major grins
    edited February 17, 2008
    I'm certain it's on the "to do list." But when my site is broken I can't rest very well... I guess I can only hope it's sooner than later....
    Hi Anthony, your site isn't broken, a hack you used to do a very specific thing is not working anymore, as a result of changes we've made. Hacks are like that. I'm going out on a limb and say that there are very few, if any, other customers using that specific hack that you have that's broken. But we will get it done, I promise you that.
  • brandofamilybrandofamily Just a Guy with a Camera Illinois USARegistered Users Posts: 2,007 Major grins
    edited February 17, 2008
    Andy wrote:
    Hi Anthony, your site isn't broken, a hack you used to do a very specific thing is not working anymore, as a result of changes we've made. Hacks are like that. I'm going out on a limb and say that there are very few, if any, other customers using that specific hack that you have that's broken. But we will get it done, I promise you that.

    I know SM is working on fixes to their new structure. I also know it is not possible to anticipate every glitch that will arise when changes are made. But if my site is not working as I intend it to then it's broken. Whether it's a hack that ceased working or not.
    I'm sure SM is "on the case." I am at your mercy since I can not fix it, nor can any of the heros... I do not like being at someone else's mercy :(
  • jfriendjfriend Scripting dude-volunteer Registered Users Posts: 8,097 Major grins
    edited February 17, 2008
    Andy wrote:
    Hi Anthony, your site isn't broken, a hack you used to do a very specific thing is not working anymore, as a result of changes we've made. Hacks are like that. I'm going out on a limb and say that there are very few, if any, other customers using that specific hack that you have that's broken. But we will get it done, I promise you that.

    Andy, this raises an interesting question for those who customize their site. How does one know what is a "supported customization" and what is a "hack" that might break at any time?
    --John
    HomepagePopular
    JFriend's javascript customizationsSecrets for getting fast answers on Dgrin
    Always include a link to your site when posting a question
  • AndyAndy Bicameral New YorkRegistered Users Posts: 50,154 Major grins
    edited February 17, 2008
    jfriend wrote:
    Andy, this raises an interesting question for those who customize their site. How does one know what is a "supported customization" and what is a "hack" that might break at any time?
    If it's on http://www.smugmug.com/help/customize-faq.mg you can bet it's supported

    If it's in the "Advanced FAQ" http://www.dgrin.com/showthread.php?t=52811 then there are cases where sometimes things might bust or need modification.

    If it's a one-off or really obscure hack, well, patience is appreciated thumb.gif
  • MarkjayMarkjay Markjay Registered Users Posts: 860 Major grins
    edited February 19, 2008
    Here are your links, Andy :-)
    Example links

    http://www.smugmug.com/keyword/all/sunflower#255491833
    twelve total thumbnails... only TWO that actually appear, the rest are blank frames!

    http://www.smugmug.com/keyword/all/flowers#256368645
    see the 6th & 7th thumbnails-blank

    http://www.smugmug.com/keyword/all/seashells#254285461
    see the 9th thumbnail-blank!

    Hope that illustrates this for you?

    Anxiously awaiting your explanation... so I can learn



    Andy wrote:
    Could be a variety of things - got a link to show us?
    Markjay
    Canon AE1 - it was my first "real camera"
    Canon 20D - no more film!
  • AndyAndy Bicameral New YorkRegistered Users Posts: 50,154 Major grins
    edited February 19, 2008
    Markjay wrote:
    Example links

    http://www.smugmug.com/keyword/all/sunflower#255491833
    twelve total thumbnails... only TWO that actually appear, the rest are blank frames!
    20080219-gyue12gpccqj91j12hntwb2xdu.jpg

    Mark, try clearing your browser's cache? I see all the thumbs there. Same for the other two links, we see 'em fine here.
  • bwgbwg SmugMug Sorcerer Northern VARegistered Users, Retired Mod Posts: 2,119 SmugMug Employee
    edited February 22, 2008
    jerryr wrote:
    thanks again for looking into this.
    As a temporary fix, I am using the window.location function

    - jerryr
    ImageKey and ImageID are now there for all templates that have a main image (and they even accurately reflect what that main image is! bonus!)
    Pedal faster
  • jerryrjerryr Smugmug Customization Registered Users Posts: 594 Major grins
    edited February 23, 2008
    bigwebguy wrote:
    ImageKey and ImageID are now there for all templates that have a main image (and they even accurately reflect what that main image is! bonus!)

    Awesome - thank you for the time and attention on this. My initial tests show success ! :) jerryr clap.gifclap.gif
  • com3com3 4theriders.com Registered Users Posts: 423 Major grins
    edited February 23, 2008
    do some of the OLD URLs to images simply not work anymore? on the entire left side of my side, i tend to rotate through images on smugmug... while the thumbs (which are hotlinked) still work, the links to the images themselves aren't working... and they're simply dropping off in random order.

    i checked them about 2 weeks ago, and all of em worked. yesterday, i noticed 2 of em didn't work anymore and when i clicked the links to the large images, it instead forwarded me to smugmug.com.

    (on my 4theriders site)

    here's one of the current thumbs that works as well as link to L that suddenly stopped working the other day, never changed the code...

    235342765-Ti.jpg
  • jfriendjfriend Scripting dude-volunteer Registered Users Posts: 8,097 Major grins
    edited February 23, 2008
    com3 wrote:
    do some of the OLD URLs to images simply not work anymore? on the entire left side of my side, i tend to rotate through images on smugmug... while the thumbs (which are hotlinked) still work, the links to the images themselves aren't working... and they're simply dropping off in random order.

    i checked them about 2 weeks ago, and all of em worked. yesterday, i noticed 2 of em didn't work anymore and when i clicked the links to the large images, it instead forwarded me to smugmug.com.

    (on my 4theriders site)

    here's one of the current thumbs that works as well as link to L that suddenly stopped working the other day, never changed the code...

    235342765-Ti.jpg

    I have a theory that external linking protection has been tightened up in the latest security changes to you should verify that external linking is allowed to any galleries that you want to use in this way.
    --John
    HomepagePopular
    JFriend's javascript customizationsSecrets for getting fast answers on Dgrin
    Always include a link to your site when posting a question
  • com3com3 4theriders.com Registered Users Posts: 423 Major grins
    edited February 23, 2008
    jfriend wrote:
    I have a theory that external linking protection has been tightened up in the latest security changes to you should verify that external linking is allowed to any galleries that you want to use in this way.


    external linking is ALWAYS allowed in my galleries.
  • AndyAndy Bicameral New YorkRegistered Users Posts: 50,154 Major grins
    edited February 23, 2008
    com3 wrote:
    external linking is ALWAYS allowed in my galleries.
    I clicked a bunch and all these links worked

    http://www.seppes.com/gallery/2884013/1/155099783/Large

    http://www.seppes.com/gallery/2547355/1/133943103/Large

    http://www.seppes.com/gallery/2884013/1/155291869/Large

    I could keep going...
  • com3com3 4theriders.com Registered Users Posts: 423 Major grins
    edited February 23, 2008
    Andy wrote:


    yeah, not all of em work...that's why i'd asked about it...cause it's hit/miss (when they worked just fine before... i haven't changed any code). *shrugs* thanks for checking, andy!

    EDIT// hehe... i just clicked to see which ones you'd checked... of course, you pick the hawtest of the hawties. :P
Sign In or Register to comment.