Videos and the API

pthpth working on itRegistered Users Posts: 49 Big grins
I see my video in the images from an API call. I also see the format tagged as 'MP4'. However the original URL points to an image and not the video. For the most part it would appear that I could "guess" the proper URLs, but this should probably be exposed in the images.get/images.getURLs calls either in the existing URLs or in new video specific URLs.

Thanks
pth

Comments

  • devbobodevbobo LR whisperer Melbourne, AURegistered Users, Retired Mod Posts: 4,339 SmugMug Employee
    edited December 5, 2007
    yeah, i'm a bit lagged on this, i'm actually working on it atm.

    i'm adding the following parameters (if they exist)...

    - Video320URL
    - Video640URL
    - Video960URL
    - Video1280URL

    Cheers,

    David
    David Parry
    SmugMug API Developer
    My Photos
  • devbobodevbobo LR whisperer Melbourne, AURegistered Users, Retired Mod Posts: 4,339 SmugMug Employee
    edited December 5, 2007
    This change is now live fpr api versions 1.2.0/1.2.1 thumb.gif
    David Parry
    SmugMug API Developer
    My Photos
  • pthpth working on it Registered Users Posts: 49 Big grins
    edited December 5, 2007
    Thanks I just verified this against my Ruby API in both 1.2.0 and 1.2.1 and it works perfect.

    pth
  • sujit1779sujit1779 Big grins Registered Users Posts: 46 Big grins
    edited September 30, 2014
    Video640URL not in API 1.3.0
    devbobo wrote: »
    yeah, i'm a bit lagged on this, i'm actually working on it atm.

    i'm adding the following parameters (if they exist)...

    - Video320URL
    - Video640URL
    - Video960URL
    - Video1280URL

    Cheers,

    David

    Hi, I couldn't find these fiedls in API 1.3.0, I need them, what should I do?

    Thanks.
Sign In or Register to comment.