WinDownload - THE Windows download utility for SmugMug users.

2

Comments

  • DsweetDsweet Big grins Posts: 81Registered Users Big grins
    edited November 22, 2010
    scotisman wrote: »
    OK, that worked fine. One difference is that I am using the "Single Album" feature (with a password).
    Thanks for noticing that. I will look into it.
  • DsweetDsweet Big grins Posts: 81Registered Users Big grins
    edited November 22, 2010
    Boyzo wrote: »
    I backup all mu Smugmug Gallery with windownload to my hard drive
    As a test I uploaded some files back up to a test folder in my Smugmug gallery and Smugmug rejects them as invalid unrecognizable file format
    Bummer !!!
    Also they are renumbered ie windownload puts 9 digits with underscore in front of the file name :(

    DEspite using the setting original file the downloaded files are not usable by Smugmug..

    The jpegs will need re-numbering and repairing

    Dont use Windownload

    USe a free Firefox plugin to transfer files from Smugmug to your computer for backup it works well and files are ORIGINAL

    I am sorry that you are having trouble, but I doubt that Windownload is the cause of your jpegs needing repairing. Thousands and thousands of files have been downloaded using windownload and you are the first to report this. More likely you have a disk drive issue. What is the error message that you are getting from smugmug when you upload? Can you open the image on your hard drive?

    I do add smugmug's unique identifier to the beginning of the filename. This is done in case you are copying files from different galleries, with the same filename, to the same destination folder.

    There are free utilities, such as renamemaster out there if you have kept your foldername/filename unique and you want to get rid of the prefix.

    Why do you want to upload the downloaded files? Are you simply planning for the possibility of a disaster where smugmug goes down? Seems like a very remote possibility. I'm curious.
  • DsweetDsweet Big grins Posts: 81Registered Users Big grins
    edited November 22, 2010
    Dsweet wrote: »
    Thanks for noticing that. I will look into it.

    This new beta version should take care of it...
    http://cldownload.50webs.com/WinDownloadInstall_v1.1.091Beta.zip
  • BoyzoBoyzo Beginner grinner Posts: 4Registered Users Beginner grinner
    edited November 22, 2010
    Dsweet wrote: »
    I am sorry that you are having trouble, but I doubt that Windownload is the cause of your jpegs needing repairing. Thousands and thousands of files have been downloaded using windownload and you are the first to report this. More likely you have a disk drive issue. What is the error message that you are getting from smugmug when you upload? Can you open the image on your hard drive?

    I do add smugmug's unique identifier to the beginning of the filename. This is done in case you are copying files from different galleries, with the same filename, to the same destination folder.

    There are free utilities, such as renamemaster out there if you have kept your foldername/filename unique and you want to get rid of the prefix.

    Why do you want to upload the downloaded files? Are you simply planning for the possibility of a disaster where smugmug goes down? Seems like a very remote possibility. I'm curious.
    Hi there
    Here is the error msg typical for all the other files d/load with windownload
    <>
    alert_icon.gif upload problem: Info: upload 'unknown file type. Would you like a SmugVault?' using POST to http://upload.smugmug.com/photos/picasa/upload.mg with Picasa/115.529999 (gzip) from 122.107.202.148 in /var/www/bzr/SmugMug/live/include/mgphotos.mgi on line 38
    <>

    I simply wanted to get back my whole gallery as a backup
    When I tried to upload to a test gallery I got errors
    I also deleted a folder on Smugmug after I had downloaded my gallery with windownload
    I though no problems I have it --- windownlaod retrieved all the gallery
    But no the files I wanted to upload back (that were lost -- deleted)
    were rejected by smugmug
    See error msg above
    I fixed the jpegs with Lighroom :)
    My HD has no issues
    The FF plugin retrieves ALL my gallery easily and as original and CAN be uploaded back to smugmug with no probs.

    Windownload did something to the retrieved files YES any jpeg viewer or editor PS CS5 or Picasa viewed them fine but damn Smugmug did NOT want them back
  • BoyzoBoyzo Beginner grinner Posts: 4Registered Users Beginner grinner
    edited November 22, 2010
    Dsweet wrote: »
    This new beta version should take care of it...
    http://cldownload.50webs.com/WinDownloadInstall_v1.1.091Beta.zip

    I'll give that a shot
    I do have great success with the FF plugin FireUploader its called
  • scotismanscotisman Big grins Posts: 10Registered Users Big grins
    edited November 22, 2010
    Boyzo wrote: »
    I'll give that a shot
    I do have great success with the FF plugin FireUploader its called

    Hey Boyzo, I will tell you what I have told all of the FireUploader marketing personnel on other threads - FireUploader is not at all what we were looking for. (Had already looked at it, and passed. It needs a more polished user interface. It tries too hard to be anything anyone might ever need for anything, and misses on the KISS design idea. Also, I'm a Chrome user. on a multi core system, firefox is too clunky.)

    I am sure there is a "FireUploader is the answer to all the worlds problems" thread. This is a thread about WinDownloader.
  • scotismanscotisman Big grins Posts: 10Registered Users Big grins
    edited November 22, 2010
    Dsweet wrote: »
    This new beta version should take care of it...
    http://cldownload.50webs.com/WinDownloadInstall_v1.1.091Beta.zip

    I'll give it a try tonight.

    EDIT: Actualy, got a chance to try it and that fixed it.
  • BoyzoBoyzo Beginner grinner Posts: 4Registered Users Beginner grinner
    edited November 22, 2010
    Dsweet wrote: »
    This new beta version should take care of it...
    http://cldownload.50webs.com/WinDownloadInstall_v1.1.091Beta.zip

    Ok tried the version above but same problem Smugmug wont accept the files I download back up to a test directory
    running windows 7
    I tried a diff HD for the download
    is microsoft .net framework a factor

    What is windownload doing to the files besides the 9 digit no
  • DsweetDsweet Big grins Posts: 81Registered Users Big grins
    edited November 23, 2010
    Boyzo wrote: »
    Ok tried the version above but same problem Smugmug wont accept the files I download back up to a test directory
    running windows 7
    I tried a diff HD for the download
    is microsoft .net framework a factor

    What is windownload doing to the files besides the 9 digit no

    If I am interpreting the error message from smugmug correctly, it looks like you are not uploading a jpg, png, or .mp4 file. Are you trying to upload a zip file? Windownload doesn't create zip files, so I don't know where that came from.

    Here is an approach:
    1. Download one of your galleries. One that has a few jpgs.
    2. Locate the jpgs you just downloaded on your HD using windows explorer. Double click on it. Can you view it? If so, then windownload worked.

    It looks to me like you have other files, that were not from windownload in the folder and when you upload these to smugmug it is reporting that the file you are trying to upload is not a jpg, png, gif, or video.

    Windownload does not change the contents of the picture. It does modify some of the files, metadata as described on the windowload web page. But that metadata does not prevent smugmug from uploading the file.
  • DsweetDsweet Big grins Posts: 81Registered Users Big grins
    edited November 23, 2010
    Boyzo wrote: »
    Hi there
    Here is the error msg typical for all the other files d/load with windownload
    <>
    alert_icon.gif upload problem: Info: upload 'unknown file type. Would you like a SmugVault?' using POST to http://upload.smugmug.com/photos/picasa/upload.mg with Picasa/115.529999 (gzip) from 122.107.202.148 in /var/www/bzr/SmugMug/live/include/mgphotos.mgi on line 38
    <>

    I simply wanted to get back my whole gallery as a backup
    When I tried to upload to a test gallery I got errors
    I also deleted a folder on Smugmug after I had downloaded my gallery with windownload
    I though no problems I have it --- windownlaod retrieved all the gallery
    But no the files I wanted to upload back (that were lost -- deleted)
    were rejected by smugmug
    See error msg above
    I fixed the jpegs with Lighroom :)
    My HD has no issues
    The FF plugin retrieves ALL my gallery easily and as original and CAN be uploaded back to smugmug with no probs.

    Windownload did something to the retrieved files YES any jpeg viewer or editor PS CS5 or Picasa viewed them fine but damn Smugmug did NOT want them back

    I just downloaded and then uploaded with no problems using windownload. Windownload is not the issue here. It works fine. Is there a way to post or send me the file you are trying to upload? The problem lies somewhere else besides windownload.
  • DsweetDsweet Big grins Posts: 81Registered Users Big grins
    edited November 23, 2010
    scotisman wrote: »
    I'll give it a try tonight.

    EDIT: Actualy, got a chance to try it and that fixed it.

    Thanks for your help.
  • DsweetDsweet Big grins Posts: 81Registered Users Big grins
    edited December 1, 2010
    Dsweet wrote: »
    Another 133 in October, now over 640 downloads...

    Another 132 downloads in November, now over 775 downloads!
  • DsweetDsweet Big grins Posts: 81Registered Users Big grins
    edited January 4, 2011
    Dsweet wrote: »
    Another 132 downloads in November, now over 775 downloads!

    Another 93 in December, so now over 868...
  • darryldarryl Major grins Posts: 1,000Registered Users Major grins
    edited May 21, 2011
    Hi David -- great tool, and woot, Keyword support, just what I was looking for.

    I found what may be a minor bug. The "header row" at the top of the lists of albums has a checkbox in the top-left corner. I thought checking it would trigger a "select all" and check all of the albums, but right now it just toggles the first album off or on.

    Ideally I would be able to select all albums and then Load Keywords and just grab the photos of one particular child. (This is for my son's preschool.)

    Let me know if you know about this bug already, and if there's a fix. But even without the fix, it's a tremendous tool. Thanks a lot!!
  • DiegeticShadowDiegeticShadow Beginner grinner Posts: 1Registered Users Beginner grinner
    edited August 2, 2011
    Album Descriptions
    Hi, is there any way to save the album description along with everything else? I get how the image captions are saved in metadata in the images, but what about the description for the album as a whole? Is there any way to save this text in the same folder as all the images, perhaps as a text file?
  • RandomSRandomS Beginner grinner Posts: 3Registered Users Beginner grinner
    edited August 18, 2011
    "Original" images not downloading
    WinDownload is a great tool, exactly what I needed! However, I'm having one problem: When I select "Original" for SmugMug Image Size, I am not getting the full-size images. They all seem to be coming down as X3Large size, in that the portrait ones are all exactly 1200 pixels tall, and the landscape ones are all 1600 pixels wide.

    I have my galleries set to a maximum size of X3Large for visitors, but I am logging in to WinDownload with my owner password, so I assume WinDownload should be able to access my Original images. Any ideas?
  • vsanchezvsanchez Beginner grinner Posts: 1Registered Users Beginner grinner
    edited April 26, 2012
    Problem logging as an owner
    Hi David,

    Great program! However, at the moment I can only download public galleries. Attempting to pass an owner password to get my private galleries gives me the following error:

    Error Login in. SmugMug Error calling smugmug.albums.get: invalid API key

    Any idea of what is wrong?

    Thanks
  • DsweetDsweet Big grins Posts: 81Registered Users Big grins
    edited May 3, 2012
    Sorry
    vsanchez wrote: »
    Hi David,

    Great program! However, at the moment I can only download public galleries. Attempting to pass an owner password to get my private galleries gives me the following error:

    Error Login in. SmugMug Error calling smugmug.albums.get: invalid API key

    Any idea of what is wrong?

    Thanks

    It looks like you found a bug. I will be releasing a new version soon.
  • SnoggerSnogger Beginner grinner Posts: 3Registered Users Beginner grinner
    edited May 9, 2012
    How to get to a password required album
    First let me say that I really dig Windownload and appreciate the time taken to code it!!!! It is the ONLY mass downloader that I have gotten to work.

    I have come across one thing that I can't figure out...

    For the site - the main site has no password but the single album does. I can't figure out what is to be entered in the login screens to get to this album. For example's sake, let's say...
    Nickname = Test123 (which comes from http://trip123.smugmug.com)
    Album Name= Group 1/Trip to Vegas 2012
    Password = ABC123

    On the "Load a User's Album List" dialog box, I enter as follows:
    > click the Album List radio button; put Test123 in the Nickname field; click the No Password radio button
    > click the Single Album radio button; put Group-1/Trip-to-Vegas-2012 in Album Key field; put ABC123 in the Album Password field
    > click Retrieve Album List

    Windownload then pauses for a moment, then pops the dialog box, "Error Logging in. Index was outside the bounds of the array."

    So what am I doing wrong?
  • nickhaighnickhaigh Major grins Posts: 285Registered Users Major grins
    edited June 8, 2012
    Hi,
    I'm guessing this software is exactly what I am needing (download all of my photos that is on my smugmug site)
    but when I run the software it says "Load a users album list" enter Nickname, I've tried my login details, my album name, my name etc but keeps saying "error invalid user"
    what do I enter to download photos?
    btw my site has no passwords

    www.nickhaigh.net
  • nickhaighnickhaigh Major grins Posts: 285Registered Users Major grins
    edited June 10, 2012
    thanks for the help!!!!!!!!!

    I have found alternative software that actually works
  • paulbrockpaulbrock Major grins Posts: 515Registered Users Major grins
    edited July 12, 2012
    which one are you using Nick?

    have to say I'm less than impressed with the inability to download more than one gallery at a time without 3rd party software.

    Getting the same 'API error' message on this one, and most of the others don't let you sort by gallery name, which after 8 years here has become a LONG list for me.

    If only the Lightroom plugin worked in both ways....
  • stufurstufur Big grins Posts: 18Registered Users Big grins
    edited August 21, 2012
    Dsweet wrote: »
    It looks like you found a bug. I will be releasing a new version soon.

    Same happened to me. I wanted to use the "owner" password in order to get hidden images as well.

    But aside from this bug I would like to thank the developer for all the effort put into this program. Really useful :)
  • Art ScottArt Scott Have PASSPORT will TRAVEL Posts: 8,957Registered Users Major grins
    edited November 19, 2012
    winDownload problem...
    why does WinDownLoad download the watermarks on my images...instead of clean originals?

    I have until 12-12 to get all my galleries downloaded.

    downloading as galleries will help with the next upload as they will all be gallery order and much more easily found rather than looking thru 10 yrs of files on various hard drives.

    thanx
    "Genuine Fractals was, is and will always be the best solution for enlarging digital photos." ....Vincent Versace ... ... COPYRIGHT YOUR WORK ONLINE ... ... My Website

    A ZENFOLIO 10% Discount Coupon CODE - A8K-Q2K-VPG
  • thegoosethegoose Beginner grinner Posts: 9Registered Users Beginner grinner
    edited December 19, 2012
    "owner" password bug
    stufur wrote: »
    Same happened to me. I wanted to use the "owner" password in order to get hidden images as well.

    But aside from this bug I would like to thank the developer for all the effort put into this program. Really useful :)

    Any progress on getting a release that fixes this bug?
  • mcgilmcgil Major grins Posts: 110Registered Users Major grins
    edited August 2, 2014
    Yep I think I'm hitting the same bug today.
    I'm using a fresh install of WinDownload v1.1.0.1 from http://cldownload.50webs.com/WinInstallation.html
    On Windows 7 Enterprise
    thegoose wrote: »
    Any progress on getting a release that fixes this bug?
  • frugalafrugala Big grins Posts: 29Registered Users Big grins
    edited September 22, 2014
    mcgil wrote: »
    Yep I think I'm hitting the same bug today.
    I'm using a fresh install of WinDownload v1.1.0.1 from http://cldownload.50webs.com/WinInstallation.html
    On Windows 7 Enterprise

    I think i was only getting my non-passworded photos/movies also. So i tried to make everything non-password and i am trying a full Windownload again. I hope this password removal trick works and it gets all files now.

    I tried a different program, PicBackMan, but it would not download the movies. I've been waiting for a fix/update for over 2 months. But in the meantime, I found this program, Windownload, and it is FAST. (PicBackMan was SLOW).

    With most of the messages here being so old, i didn't think Windownload would work on the new SmugMug. And i was pretty excited when it did.

    As a sidebar: it is pretty lame and unprofessional of SmugMug to list upload/download tools on their website, when MOST of them do not work! I think that this program, Windownload, is the only program in their download list that actually works.

    OK, back on topic - this WinDownload program is awesome and thank you so much for developing it!
  • frugalafrugala Big grins Posts: 29Registered Users Big grins
    edited September 22, 2014
    I am getting a few "generic error in GDI+" and so far they all are showing up as 1KB files with nothing in them.
    Does anyone know root cause on this error? Is there something goofy with my Smugmug? Or is this a "Busy Network" kind of error?
    thanks

    example message:

    1826859204_IMG_0438.jpg: A generic error occurred in GDI+.
  • DsweetDsweet Big grins Posts: 81Registered Users Big grins
    edited November 24, 2014
    the header row check box will check or uncheck all the "selected rows"
    darryl wrote: »
    Hi David -- great tool, and woot, Keyword support, just what I was looking for.

    I found what may be a minor bug. The "header row" at the top of the lists of albums has a checkbox in the top-left corner. I thought checking it would trigger a "select all" and check all of the albums, but right now it just toggles the first album off or on.

    Ideally I would be able to select all albums and then Load Keywords and just grab the photos of one particular child. (This is for my son's preschool.)

    Let me know if you know about this bug already, and if there's a fix. But even without the fix, it's a tremendous tool. Thanks a lot!!

    To try this check a row, hold the shift key down and then check another row several rows down, all the selected rows should now be select (hilighted (blue)). Now click the header check box and all the selected rows will be set to the header check box value.
  • DsweetDsweet Big grins Posts: 81Registered Users Big grins
    edited December 17, 2014
    Updated version now available
    The new version addresses two of the requests from users:
    1. Login as owner
    2. Use the original file name.
2
Sign In or Register to comment.