DGrin is Now on Vanilla Forums

leftquarkleftquark SmugMug Product TeamPosts: 2,972Administrators, Vanilla Admin, SmugMug Product Team SmugMug Employee

As most of you have noticed, DGrin looks a little different today! That's because we've finally upgraded the software behind DGrin to use "Vanilla Forums". Things will be a little different and they'll take some getting used to, but we're in a much better platform that will allow us to continue having amazing photography and SmugMug related discussions!

I urge you to try posting a few comments and familiarize yourself with the new software, and to post any questions or feedback you may have in this thread.

You'll notice we switched away from BBCode and over to Markdown, since Markdown is now becoming the standard for applying text markups to your posts.

We'll continue to tweak the look and feel and cleanup some of the threads and categories as we get comfortable with the new DGrin. Stay tuned for more!

SmugMug Director of Product / dGrin Afficionado
aaron AT aaronmphotography DOT com
Website: http://www.aaronmphotography.com
My SmugMug CSS Customizations website: http://www.aaronmphotography.com/Customizations
«13456716

Comments

  • sarasphotossarasphotos Major grins Augsburg, GermanyPosts: 1,714Registered Users Major grins
    edited December 6, 2016

    I'm getting used to it... I haven't quite figured out how to get immediately to the last post of a thread. ...and it all seems very LARGE. But I'm sure it will grow on me... and those green sticky posts are awfully, well... GREEN

  • BenBen SmugMug VP of Operations Posts: 512Vanilla Admin SmugMug Employee

    Yeah, there's definitely a lot of "new" to adjust to. We'll keep tweaking the visual stuff too as we discover what we hate versus just what we will get used to. :)

    Smug since 2003
  • JtringJtring Major grins CaliforniaPosts: 380Registered Users Major grins
    edited December 6, 2016

    Two initial observations:

    In an thread listing, the date of the first post is in a medium gray (#888888) but the dates of subsequent posts are a little darker (#555555). That latter is almost invisible -- at least my old eyes -- against the just slightly darker gray (#3c3c3c) background. How about adjusting the tone to provide more contrast between those dates and the background?

    Is there a "jump to first unread" button somewhere? I don't see it, but I'm still wandering around. For long threads that was really helpful back on the old forum software.

    Jim Ringland . . . . . jtringl.smugmug.com
  • BenBen SmugMug VP of Operations Posts: 512Vanilla Admin SmugMug Employee

    Hey @Jtring, thanks for the feedback. I'll pass along the color suggestions... we're still definitely tweaking colors and theme as we use it. Expect to see some changes in the next few minutes (like those super bright sticky thread highlights will change shortly). We'll find something beautiful and useful sooner or later. :smiley:

    Not sure on the jump to first unread. I agree, great feature. I'll go hunting in the settings and get back to you if I find it.

    Smug since 2003
  • JtringJtring Major grins CaliforniaPosts: 380Registered Users Major grins

    Oh, that's interesting. I tried to edit my first comment using the little gear icon up top. (Find the difference?) I got a second post rather than a replacement to the first.

    Jim Ringland . . . . . jtringl.smugmug.com
  • denisegoldbergdenisegoldberg Major grins North Andover, MAPosts: 11,129Super Moderators moderator

    Congrats on a successful move to the new software!

    I have a couple of questions / issues. First, I used the old software with a light background and dark text since I find that easier on my eyes than light on dark. I haven't been able to find an option to switch the display to dark on light. Does this option exist?

    I just looked at my inbox and I don't see any way to remove messages. There are more messages in my inbox than were active on the old dgrin. I had deleted many messages there and the deleted messages have reappeared. I'm thinking I'm just looking past the delete capability. Is it possible to delete old messages?

    --- Denise

  • BenBen SmugMug VP of Operations Posts: 512Vanilla Admin SmugMug Employee

    @denisegoldberg There isn't a way to switch between your own themes in the same way, other than using something 3rd party like GreaseMonkey (which I do use and like on various sites by the way).

    Messages are a bit different here on Vanilla, as they act more like conversations in chat software like Slack or iMessages. You can leave any conversation by clicking through to it and hitting the red Leave button. I don't see a bulk Leave option for all the ancient conversations though.

    Smug since 2003
  • JtringJtring Major grins CaliforniaPosts: 380Registered Users Major grins

    OK. I closed the thread and came back, and now my edited post looks right, with no duplicate before-and-after post. I guess the display during the edit process isn't as I expected. Feature, not a bug ...

    Jim Ringland . . . . . jtringl.smugmug.com
  • denisegoldbergdenisegoldberg Major grins North Andover, MAPosts: 11,129Super Moderators moderator

    Thanks Ben.
    I tried to use the red leave button. It just pops up a circling set of lines at the top of the browser window but doesn't ever finish spinning and also doesn't remove the message. I've tried this in Firefox and Chrome with the same behavior.

  • pegellipegelli Major grins BelgiumPosts: 2,893Registered Users Major grins

    When I try to edit a post to add/change an image the drop down seems inactive

    Pieter, aka pegelli
    My SmugMug
  • BenBen SmugMug VP of Operations Posts: 512Vanilla Admin SmugMug Employee

    @denisegoldberg hmm, I'll poke around a bit and report it to Vanilla (our new forum host/provider). I'm sure we'll find lots of weird quirks or bugs as we dig in. No platform is perfect, not even gasp SmugMug. :joy:

    @pegelli Hmm, yeah I can replicate that. I'll see if that is a setting or a "feature".

    Smug since 2003
  • JtringJtring Major grins CaliforniaPosts: 380Registered Users Major grins

    Thanks for the responses Ben. One more spot where some extra contrast would enhance readability. On the list of threads in a forum, the detail line -- things like "1.9K Views 4 Comments Most recent ..." -- seems rather too dim. It's that medium-dark gray text (#555555) again, this time on a some what darker but still not-quite-black background (#222222).

    Jim Ringland . . . . . jtringl.smugmug.com
  • AllenAllen "tweak 'til it squeaks" St. Louis, MoPosts: 9,234Registered Users Major grins

    How do I quote something I'm answering? I see nothing.

    Al - Just a volunteer here having fun
    My Website | My Blog
  • Paul IddonPaul Iddon Major grins Posts: 4,650Registered Users Major grins

    I've posted from Smugmug hosting page into a macro thread, but all it does it link to the photos instead of showing them in the thread...

    Paul.



    Link to my personal website: http://www.pauliddon.co.uk


    Canon Users Only Website: http://www.canon-fodder-forums.com/




  • BenBen SmugMug VP of Operations Posts: 512Vanilla Admin SmugMug Employee

    @Allen said:
    How do I quote something I'm answering? I see nothing.

    See the little blue icon in the bottom left, next to the other reactions? It's a little hidden, I really want to move it somewhere else. For now, that's where it lives....

    Smug since 2003
  • cabbeycabbey SmugMug Sorcerer Wilsonville, ORPosts: 1,053Registered Users Major grins

    @Ben said:

    @Allen said:
    How do I quote something I'm answering? I see nothing.

    See the little blue icon in the bottom left, next to the other reactions? It's a little hidden, I really want to move it somewhere else. For now, that's where it lives....

    That brings up another bit of text that needs some contrast love.

    SmugMug Sorcerer - Engineering Team Champion for Commerce, Finance, Security, and Data Support
    http://wall-art.smugmug.com/
  • BenBen SmugMug VP of Operations Posts: 512Vanilla Admin SmugMug Employee

    @Paul Iddon said:
    I've posted from Smugmug hosting page into a macro thread, but all it does it link to the photos instead of showing them in the thread...

    There are two ways to embed the images directly in the post. The easiest is to use the little icon right above the text box, on the right side (that looks like a piece of paper). You can click that, and paste the image URL into that.

    You can also manually format it with Markdown. The formatting for images manually is a little funny, but you can see a cheat sheet right here

    Smug since 2003
  • grandmaRgrandmaR Major grins Posts: 1,580Registered Users Major grins

    I had certain topics marked so that when I logged in, I had a list of those topics. I can't figure out how to get to that point. The closest I have come is bookmarks and I can't seem to get a page of bookmarked items come up when I log on.

    “"..an adventure is an inconvenience rightly considered." G.K. Chesterton”
    http://members.virtualtourist.com/m/4a9c6/
  • BenBen SmugMug VP of Operations Posts: 512Vanilla Admin SmugMug Employee

    @grandmaR said:
    I had certain topics marked so that when I logged in, I had a list of those topics. I can't figure out how to get to that point. The closest I have come is bookmarks and I can't seem to get a page of bookmarked items come up when I log on.

    I think this link should work for all your bookmarks.

    Smug since 2003
  • Paul IddonPaul Iddon Major grins Posts: 4,650Registered Users Major grins

    @Ben said:

    @Paul Iddon said:
    I've posted from Smugmug hosting page into a macro thread, but all it does it link to the photos instead of showing them in the thread...

    There are two ways to embed the images directly in the post. The easiest is to use the little icon right above the text box, on the right side (that looks like a piece of paper). You can click that, and paste the image URL into that.

    You can also manually format it with Markdown. The formatting for images manually is a little funny, but you can see a cheat sheet right here

    Tried that (not the cheatsheet bit, the linking) but using [img] and the [/img] format didn't work



    Link to my personal website: http://www.pauliddon.co.uk


    Canon Users Only Website: http://www.canon-fodder-forums.com/




  • BenBen SmugMug VP of Operations Posts: 512Vanilla Admin SmugMug Employee

    @Paul Iddon said:

    Tried that (not the cheatsheet bit, the linking) but using [img] and the [/img] format didn't work

    Yeah, we've moved to the more industry standard Markdown on Vanilla instead of bbcode that vBulletin used.

    Markdown is used across a lot more industries and is more standard, bbcode was primarily just used by a few older forums. There's not a great answer, because both have learning curves. This hopefully future proofs us a bit more.

    Smug since 2003
  • denisegoldbergdenisegoldberg Major grins North Andover, MAPosts: 11,129Super Moderators moderator

    Awesome! The forum is now nicely usable on a phone without requiring 3rd party software.
    I use it more from a computer but sometimes the phone is the device at hand.

    --- Denise

  • AllenAllen "tweak 'til it squeaks" St. Louis, MoPosts: 9,234Registered Users Major grins
    edited December 6, 2016

    One huge problem is the posts are not numbered. Will never be able to refind a post or refer to an existing post.
    example: "See post #xx for the answer".

    Al - Just a volunteer here having fun
    My Website | My Blog
  • AllenAllen "tweak 'til it squeaks" St. Louis, MoPosts: 9,234Registered Users Major grins
    edited December 6, 2016

    I have always used a browser bookmark directly to the Support forum. Now seems like I can only go to entire site.
    None of the homepage section heads are now a link.

    Al - Just a volunteer here having fun
    My Website | My Blog
  • BenBen SmugMug VP of Operations Posts: 512Vanilla Admin SmugMug Employee

    @Allen said:
    One huge problem is the posts are not numbered. Will never be able to refind a post or refer to an existing post.
    example: "See post #xx for the answer".

    There isn't a specific post number I can see, I can look to see if I can enable it somewhere but you can permalink specific posts.

    For instance, picking one of my posts above, you could do:
    See this post for answer

    The permalink is found on the time (like 2:37PM) in the title bar of the post.

    Smug since 2003
  • BenBen SmugMug VP of Operations Posts: 512Vanilla Admin SmugMug Employee

    @Allen said:
    I have always used a browser bookmark directly to the Support forum. Now seems like I can only go to entire site.
    None of the homepage section heads are now a link.

    They all still have a landing page, the links have just been removed for simplifying navigation. You can still easily bookmark any you want though, like:
    Support
    or
    Shots

    Smug since 2003
  • AllenAllen "tweak 'til it squeaks" St. Louis, MoPosts: 9,234Registered Users Major grins

    @Ben said:

    @Allen said:
    One huge problem is the posts are not numbered. Will never be able to refind a post or refer to an existing post.
    example: "See post #xx for the answer".

    There isn't a specific post number I can see, I can look to see if I can enable it somewhere but you can permalink specific posts.

    For instance, picking one of my posts above, you could do:
    See this post for answer

    The permalink is found on the time (like 2:37PM) in the title bar of the post.

    Took some time but it looks like if you right click on time you can copy the posts link. Otherwise there is no visible way to see it.

    Al - Just a volunteer here having fun
    My Website | My Blog
  • AllenAllen "tweak 'til it squeaks" St. Louis, MoPosts: 9,234Registered Users Major grins
    edited December 6, 2016

    Looks like I've lost 10's of thousands of posts?
    :D BTW, did we lose the grin? :D << not the right one.

    Al - Just a volunteer here having fun
    My Website | My Blog
  • BenBen SmugMug VP of Operations Posts: 512Vanilla Admin SmugMug Employee

    @Allen said:
    Looks like I've lost 10's of thousands of posts?
    :D BTW, did we lose the grin? :D << not the right one.

    I think the lost posts were in old forums we finally deleted that have been hidden for a long time. I bet your posts were from the Legacy Customization forum. :disappointed:

    Smug since 2003
  • BenBen SmugMug VP of Operations Posts: 512Vanilla Admin SmugMug Employee

    And yeah, emojis are more limited over here. That's my top feature request, I want custom emojis!!
    :neutral:

    Smug since 2003
«13456716
Sign In or Register to comment.