SmuggLr - for flickr, Phanfare, PicasaWeb, PhotoSite & Zenfolio refugees

2456710

Comments

  • wngwng Beginner grinner Posts: 1Registered Users Beginner grinner
    edited October 3, 2007
    Thanks for coming up with such a great app!

    I tried it on one of my Imagestation galleries I set up before joining Smugmug and it worked great. Since it's still in beta, I thought you might want to know two things I noticed:

    1. Transferred captions got cut off whenever there was a quotation character ("). The caption stopped right before the quotation character.

    2. The order of the photos is different. I haven't figured out yet how Smugmug sorted the transferred photos.


    Thanks!
  • devbobodevbobo LR whisperer Melbourne, AUPosts: 4,335Administrators SmugMug Employee
    edited October 3, 2007
    wng wrote:
    Thanks for coming up with such a great app!

    I tried it on one of my Imagestation galleries I set up before joining Smugmug and it worked great. Since it's still in beta, I thought you might want to know two things I noticed:

    1. Transferred captions got cut off whenever there was a quotation character ("). The caption stopped right before the quotation character.

    2. The order of the photos is different. I haven't figured out yet how Smugmug sorted the transferred photos.


    Thanks!


    G'day wng,

    Welcome to dgrin and SmugMug wave.gif.

    I will see what I can do.

    Cheers,

    David
    David Parry
    SmugMug API Developer
    My Photos
  • devbobodevbobo LR whisperer Melbourne, AUPosts: 4,335Administrators SmugMug Employee
    edited October 11, 2007
    bump for new release
    David Parry
    SmugMug API Developer
    My Photos
  • flyingdutchieflyingdutchie Happy Snapper Posts: 1,286Registered Users Major grins
    edited October 11, 2007
    devbobo wrote:
    bump for new release

    I donwloaded the new release and tried to upload my failing albums from ImageStation to Smugmug (see my earlier message in this thread).

    I still get the same error in the upload-log of smugmug:
    1x1-gray.gifn/a1x1-gray.gif|Error|1x1-gray.gif2007-09-25 05:18:17|1x1-gray.gifn/a|1x1-gray.gifn/a|upload problemwrong bytes received1x1-gray.gif

    But SmuggLr now seems to hang (instead of saying it has completed successfully) and my upload-log in smugmug creates the above Error message about 3 times per second until i push 'Cancel' on the SmuggLr application.

    Any idea what could cause this?

    Thanks!
    -- Anton Spaans.
    I can't grasp the notion of time.

    When I hear the earth will melt into the sun,
    in two billion years,
    all I can think is:
        "Will that be on a Monday?"
    ==========================
    http://www.streetsofboston.com
    http://blog.antonspaans.com
  • devbobodevbobo LR whisperer Melbourne, AUPosts: 4,335Administrators SmugMug Employee
    edited October 11, 2007
    Any idea what could cause this?

    it appears that some of the images are currently unavailable from ImageStation and my error handling code was dumb :D

    released v1.3 with image retries set to 3.
    David Parry
    SmugMug API Developer
    My Photos
  • CRR3143CRR3143 Beginner grinner Posts: 1Registered Users Beginner grinner
    edited November 29, 2007
    MyPhotoAlbum.com
    I have a ton of photos I'd like to Migrate from myphotoalbum.com to smugmug. Do you know if there is any way to do this?
  • tracymtntracymtn Beginner grinner Posts: 1Registered Users Beginner grinner
    edited December 4, 2007
    Imagestation Smugglr Help
    I am having trouble getting some of my Imagestation albums over to SmugMug. There are no error messages given. The album will created, but no pictures are moved over. Some albums came over fine, but the others are not coming. Is there any help that can be offered?
    Thanks!
  • devbobodevbobo LR whisperer Melbourne, AUPosts: 4,335Administrators SmugMug Employee
    edited December 20, 2007
    bump...added support for Phanfare
    David Parry
    SmugMug API Developer
    My Photos
  • jeff318jeff318 shoeboxsavior.com Posts: 16Registered Users Big grins
    edited December 21, 2007
    Any possibility of adding Kodak Gallery (formerly ofoto) support?

    I have thousands of photos on there, and don't want to pay for an archive CD from them.
    www.shoeboxsavior.com
    shoeboxsavior.smugmug.com
    digitizing your family's memories
  • devbobodevbobo LR whisperer Melbourne, AUPosts: 4,335Administrators SmugMug Employee
    edited December 21, 2007
    jeff318 wrote:
    Any possibility of adding Kodak Gallery (formerly ofoto) support?

    I have thousands of photos on there, and don't want to pay for an archive CD from them.

    Jeff,

    I will look into it, but some of those big ones (like shutterfly and snapfish) a repretty closed, which makes it almost impossible to integrate.

    Cheers,

    David
    David Parry
    SmugMug API Developer
    My Photos
  • typoprtypopr Beginner grinner Posts: 1Registered Users Beginner grinner
    edited January 20, 2008
    Flickr Hangs on photo processing
    I'm having problems with some of my larger galleries on Flickr making their way over to SmugMug. It creates the directory on SmugMug, then when it gets very near the end of processing all the images from the directory I've chosen, it hangs without transferring any images.

    This only seems to happen on galleries with more than 100 images.

    Any thoughts?

    Thanks. Great piece of software otherwise.
  • lildudelildude Big grins Posts: 70Registered Users Big grins
    edited January 29, 2008
    Newline taking no effect
    Hi there

    I'm currently experimenting with Smugglr in preparation of moving my entire collection from Flickr to SmugMug (in preparation of releasing some new code based on phpSmug mwink.gif ) and I've found that the new line (\n) added between the title and description, when selecting "add flickr photo description to end of photo title" is being removed by the SmugMug backend code.

    The line of code in question in smuggLr.js is:
       963        if (SmuggLr.appendDescription && json.photo.description._content != "")
       964          inst.title += ' \n' + json.photo.description._content;
    

    Changing "\n" to "<br />" gets round this, but it doesn't look very nice when a user edits the photo caption within SmugMug. I'm happy to use "<br />", but other users may not be.

    Do you have any ideas of another way around this? I think some sort of separator is needed, and a newline is as good as any.
    Colin Seymour
    Personal Blog | Tech Blog | phpSmug
  • devbobodevbobo LR whisperer Melbourne, AUPosts: 4,335Administrators SmugMug Employee
    edited January 29, 2008
    lildude wrote:
    Hi there

    I'm currently experimenting with Smugglr in preparation of moving my entire collection from Flickr to SmugMug (in preparation of releasing some new code based on phpSmug <img src="https://us.v-cdn.net/6029383/emoji/mwink.gif"; border="0" alt="" > ) and I've found that the new line (\n) added between the title and description, when selecting "add flickr photo description to end of photo title" is being removed by the SmugMug backend code.

    The line of code in question in smuggLr.js is:
       963        if (SmuggLr.appendDescription && json.photo.description._content != "")
       964          inst.title += ' \n' + json.photo.description._content;
    
    Changing "\n" to "<br />" gets round this, but it doesn't look very nice when a user edits the photo caption within SmugMug. I'm happy to use "<br />", but other users may not be.

    Do you have any ideas of another way around this? I think some sort of separator is needed, and a newline is as good as any.

    Colin,

    I will have a look and let you know.

    Cheers,

    David
    David Parry
    SmugMug API Developer
    My Photos
  • devbobodevbobo LR whisperer Melbourne, AUPosts: 4,335Administrators SmugMug Employee
    edited February 11, 2008
    bump, added support for Picasa Web and fixed flickr append description bug
    David Parry
    SmugMug API Developer
    My Photos
  • gemindergeminder Beginner grinner Posts: 3Registered Users Beginner grinner
    edited February 14, 2008
    Invalid API error - any suggestions
    I searched the thread, but was not able to find anyone having this issue. So, apologies if I missed it. I have installed the SmuggLr Firefox extension, entered my Yahoo/Flickr account info, select one of my Flickr sets to "move" to SmugMug, and then receive an "alert - fail - invalid API key" notice.

    254595358_MshAw-M.png

    So, any suggestions as to where I have gone wrong?
  • devbobodevbobo LR whisperer Melbourne, AUPosts: 4,335Administrators SmugMug Employee
    edited February 14, 2008
    geminder wrote:
    I searched the thread, but was not able to find anyone having this issue. So, apologies if I missed it. I have installed the SmuggLr Firefox extension, entered my Yahoo/Flickr account info, select one of my Flickr sets to "move" to SmugMug, and then receive an "alert - fail - invalid API key" notice.

    254595358_MshAw-M.png

    So, any suggestions as to where I have gone wrong?

    hmm... that's strange, try installing the most recent version from here.
    David Parry
    SmugMug API Developer
    My Photos
  • gemindergeminder Beginner grinner Posts: 3Registered Users Beginner grinner
    edited February 15, 2008
    devbobo wrote:
    hmm... that's strange, try installing the most recent version from here.
    Hmmmm... still the same issue. I tried reinstalling the SmuggLr extension. I went into my Flickr account, removed the SmuggLr permissions, set it up again, and still had the same issue. In Flickr, the permissions show that SmuggLr has permission to "read".

    I am working on a Mac - I may try to install the extension on a PC and see if it works...
  • devbobodevbobo LR whisperer Melbourne, AUPosts: 4,335Administrators SmugMug Employee
    edited February 15, 2008
    geminder wrote:
    Hmmmm... still the same issue. I tried reinstalling the SmuggLr extension. I went into my Flickr account, removed the SmuggLr permissions, set it up again, and still had the same issue. In Flickr, the permissions show that SmuggLr has permission to "read".

    I am working on a Mac - I may try to install the extension on a PC and see if it works...

    Try clearing the Firefox cookie and try again.

    Does this occur on the SmugMug login screen ?

    Cheers,

    David
    David Parry
    SmugMug API Developer
    My Photos
  • gemindergeminder Beginner grinner Posts: 3Registered Users Beginner grinner
    edited February 15, 2008
    devbobo wrote:
    Try clearing the Firefox cookie and try again.

    Does this occur on the SmugMug login screen ?

    Cheers,

    David

    So... cleared Firefox cookie, tried it on PC instead of Mac, tried resetting my Flickr permissions again, and still no luck.

    The error displays on the SmugMug login screen, but seems to have nothing to do with the SmugMug login info. I can type in the username "ABC" and password "ABC" and still get the same error.
  • norbsnorbs Beginner grinner Posts: 1Registered Users Beginner grinner
    edited February 19, 2008
    Is http://www.smugglr.net/ down at the moment David?
  • devbobodevbobo LR whisperer Melbourne, AUPosts: 4,335Administrators SmugMug Employee
    edited February 21, 2008
    bump for version 1.9, added Zenfolio and fixed a few things
    David Parry
    SmugMug API Developer
    My Photos
  • darryldarryl Major grins Posts: 1,000Registered Users Major grins
    edited February 22, 2008
    Wah, no Phanfare 2.0 support?

    Anyways, similar to the problem with SmugBrowser, Firefox prompted me about the new version (1.9), but then proceeded to "update" to 1.8.

    Thanks.

    --Darryl
  • devbobodevbobo LR whisperer Melbourne, AUPosts: 4,335Administrators SmugMug Employee
    edited February 22, 2008
    darryl wrote:
    Wah, no Phanfare 2.0 support?

    Anyways, similar to the problem with SmugBrowser, Firefox prompted me about the new version (1.9), but then proceeded to "update" to 1.8.

    Thanks.

    --Darryl

    Phanfare have indicated that they won't have their API bug fixed until early March, so as soon as that is released, I will release my code. Unless you want to follow them up in the mean time. thumb.gif

    I just triple checked the automatic upgrade process and it worked fine for me ne_nau.gif
    David Parry
    SmugMug API Developer
    My Photos
  • goldenstarphotogoldenstarphoto Major grins Foresthill, CAPosts: 252Registered Users Major grins
    edited February 24, 2008
    Is Smugglr down?
    I've been trying all weekend to move my photos over from Flickr....but I keep getting the following message when I attempt to upload the software...

    Server not found

    Firefox can't find the server at www.smugglr.net.


    * Check the address for typing errors such as
    ww.example.com instead of
    www.example.com

    * If you are unable to load any pages, check your computer's network
    connection.

    * If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.

    Any ideas when it will be up?

    Thanks,
    Doug
  • threeceethreecee Beginner grinner Posts: 2Registered Users Beginner grinner
    edited February 25, 2008
    where can i download the smugglr plugin?
    when i go to http://www.smugglr.net, i don't see the "Install now" icon. i'm using the latest version of Firefox on a mac.

    maybe i just need that 2nd cup of coffee, but i can't figure out how to download the plugin. help!
  • devbobodevbobo LR whisperer Melbourne, AUPosts: 4,335Administrators SmugMug Employee
    edited February 25, 2008
    threecee wrote:
    when i go to http://www.smugglr.net, i don't see the "Install now" icon. i'm using the latest version of Firefox on a mac.

    maybe i just need that 2nd cup of coffee, but i can't figure out how to download the plugin. help!

    Sorry had a few dns issues :D

    If you can't reach www.smugglr.net yet, PM me your email address and I will email you the installation file.
    David Parry
    SmugMug API Developer
    My Photos
  • threeceethreecee Beginner grinner Posts: 2Registered Users Beginner grinner
    edited February 26, 2008
    devbobo wrote:
    Sorry had a few dns issues :D

    If you can't reach www.smugglr.net yet, PM me your email address and I will email you the installation file.

    works now. thanks!
  • simosimo Beginner grinner Posts: 2Registered Users Beginner grinner
    edited March 6, 2008
    threecee wrote:
    works now. thanks!

    I was trying to import my pics from picasaweb but after I enter my information into picasaweb, I'm just being logged into my picasaweb "My Photos" page and unable to proceed from there. Anyone else facing this problem?
  • AlimoAlimo Beginner grinner Posts: 1Registered Users Beginner grinner
    edited March 13, 2008
    simo wrote:
    I was trying to import my pics from picasaweb but after I enter my information into picasaweb, I'm just being logged into my picasaweb "My Photos" page and unable to proceed from there. Anyone else facing this problem?

    I, too, am trying to import from PicasaWeb and am experiencing the same results when I log in. Since there is no indication of what should happen next, I'm at a loss as to what is wrong.
  • livverlipslivverlips Primitivejim.com Posts: 31Registered Users Big grins
    edited March 23, 2008
    Hi guys,

    I was wondering if you have worked on getting a tool for transferring from pbase.com.

    I have thousands of pics Id like to move over if possible.

    Thanks

    p.s. im on a mac if it matters
Sign In or Register to comment.